2000 S430 Wont Start - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 02-25-2009, 03:23 PM Thread Starter
BenzWorld Junior Member
Date registered: Feb 2009
Vehicle: 2000 S430
Location: Atlanta, Georgia
Posts: 13
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Angry 2000 S430 Wont Start

My 2000 S430 wont start. I get the message "Display Defective ESP Visit Workshop". Took it to dealer and after running diagnostic for over half a day. They did not have any idea. This has happen three days in a row. Don't know why it start then later in the day decides not to. Any ideas?
MeRule is offline  
Sponsored Links
post #2 of 3 (permalink) Old 02-25-2009, 05:11 PM
BenzWorld Member
PLeeson's Avatar
Date registered: Apr 2007
Vehicle: 2012 S550 4Matic
Location: Iowa
Posts: 385
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
My first idea would be to find a different mechanic.
A non-start condition should be solvable...


Prior MBs:
1971 250, 1983 380SEL
1986 190E2.3, 1987 300TD
1994, 2003, 2005 SL500s
2001 E320 4Matic
2011, 2012 E350 4Matics
PLeeson is offline  
post #3 of 3 (permalink) Old 02-25-2009, 05:22 PM
BenzWorld Elite
Check Codes's Avatar
Date registered: Mar 2005
Vehicle: '01-E320 & 02-ST2
Location: John 15:18-19
Posts: 31,634
Mentioned: 0 Post(s)
Quoted: 35 Post(s)
Welcome to the forum. Please click the User CP link and complete your BW profile re: vehicle and location as that is often useful information.

I'd tend to agree with PLeeson about the dealer.

That said, my first thought (aside from your ESP message) is a crank position sensor, but if they didn't specifically test for that it's possible they could miss that.

Take care and enjoy the ride,

Socialism is a philosophy of failure, the creed of ignorance, and the gospel of envy; its inherent virtue is the equal sharing of misery. (Winston Churchill)
Check Codes is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    2000 S430 Won't Start... mike_t W220 S-Class 11 09-06-2012 01:26 AM
    s430 wont start...help!!!!!!!!!!! VMAX7 W220 S-Class 26 01-03-2012 07:00 AM
    2000 S430 won't start taxiking W220 S-Class 3 07-30-2005 10:59 AM
    2000 S430 Wont start enjone W220 S-Class 1 06-01-2005 10:34 AM
    Is there a way to add remote start to my 2000 S430? Roadan W220 S-Class 0 10-20-2004 07:32 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome