2001 ML320 trip computer - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 02-22-2009, 07:41 AM Thread Starter
BenzWorld Senior Member
 
01ml320benzito's Avatar
 
Date registered: Feb 2009
Vehicle: 2004 ML350, 1999 C230K
Location: Georgia
Posts: 483
Mentioned: 0 Post(s)
Quoted: 17 Post(s)
(Thread Starter)
Post 2001 ML320 trip computer

My 2001 ML320 is equipped with the trip computer that tells you direction, mpg, etc. I turned off the car one day and noticed it read "on" so for some odd reason I decided to press the "reset" button and it then read "off". It never turned on again and it still hasn't turned on. I tried several combinations of pressing mode and reset and I can't find anything in the manual. How do I turn the trip computer back on?
01ml320benzito is online now  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 02-22-2009, 09:12 AM
BenzWorld Elite
 
Kajtek1's Avatar
 
Date registered: Dec 2005
Vehicle: W211 E320 Bluetec R129 SL500 - $1300 car ........ Ford F350 6l
Location: CA Bay Area
Posts: 31,776
Mentioned: 9 Post(s)
Quoted: 1123 Post(s)
reset properly turned it off, but the same button should turn it back on.
If you want to change display you use mode button.
Kajtek1 is online now  
post #3 of 5 (permalink) Old 02-22-2009, 09:58 AM Thread Starter
BenzWorld Senior Member
 
01ml320benzito's Avatar
 
Date registered: Feb 2009
Vehicle: 2004 ML350, 1999 C230K
Location: Georgia
Posts: 483
Mentioned: 0 Post(s)
Quoted: 17 Post(s)
(Thread Starter)
Reset?

I pressed reset several times in different key positions and it still didn't work!???

o it doesn't read "off" anymore it is just blank
01ml320benzito is online now  
post #4 of 5 (permalink) Old 02-22-2009, 01:57 PM
BenzWorld Elite
 
Kajtek1's Avatar
 
Date registered: Dec 2005
Vehicle: W211 E320 Bluetec R129 SL500 - $1300 car ........ Ford F350 6l
Location: CA Bay Area
Posts: 31,776
Mentioned: 9 Post(s)
Quoted: 1123 Post(s)
"Huston we have a problem"
Check the fuses. Everything else work OK?
Kajtek1 is online now  
post #5 of 5 (permalink) Old 02-22-2009, 02:24 PM
BenzWorld Elite
 
DirectLA's Avatar
 
Date registered: Jan 2007
Vehicle: 1962 W111 220SE Coupe
Location: Cloud City, OR
Posts: 2,289
Mentioned: 1 Post(s)
Quoted: 8 Post(s)
I see you are a new member, you may not have noticed there is a section specifically dedicated to the ML. You may get more responses in front of a model specific audience. Good luck, welcome and enjoy your new-to-you ride!

-Marrs

The Coupe Group (W111/112 coupes and cabs)official website
The Coupe Group on Facebook


"Too many people are working at jobs they hate, to buy things they don't particularly want, to impress people they don't even care about." --Dr. Deepak Chopra
DirectLA is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    ML320 overhead trip computer wanted mrmayhem For Sale/Wanted/Trade/Giveaway 0 12-12-2008 01:23 PM
    1999 ML320 Trip Computer Schuters W163 M-Class 9 08-26-2004 03:13 PM
    Cant Get the trip Computer on my 1999 ML320 to work[?] _FeRaRiOnUr_ W163 M-Class 5 04-21-2004 10:23 AM
    Retrofitted Trip Computer into ML 320 2001.. I have 9 fingers now.... AC_ML W163 M-Class 3 10-13-2002 08:28 PM
    Trip computer/alarm trip resolution (hopefully) pmo W163 M-Class 10 05-08-2002 10:09 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome