1988 300SE - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 02-15-2009, 05:28 AM Thread Starter
BenzWorld Junior Member
Gary'88300SE's Avatar
Date registered: Feb 2009
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Post 1988 300SE


I have recenlty purchased my first mercedes and have around 6 months to gether into pristine condition. I hav joined this site to hopefully recieve some helpful hints and tips from experienced 300se restorers. My engine and gearbox seem to be in good working order and the repairsare mainly cosmetic (My Avatar is my goal) when I took delivery of the car the battery was flat and after getting it jump started when I removed the jump leads she just cut out? I have no done a thorugh charge on the battery and seems to be ok (I have fired her up every day for the last week and dont think the ba1ttery alone could have managed that) There is no alternator coming on even when I turn the ignition, having said that the n/s indicator (In instrument panel) doesnt work either. I think my first job therefore is to pull out the intrument panel cluster.... any tips?
Also the other thing that needs urgent attention is the exhaust as it is blowing and rattling so again any hints and tips would be very welcome.
Gary'88300SE is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    1988 300SE questions and comments. akimball442 W126 S,SE,SEC,SEL,SD,SDL Class 6 06-06-2008 10:02 AM
    Starting Problem 1988 300SE thecarwashguy W126 S,SE,SEC,SEL,SD,SDL Class 2 08-31-2006 03:38 AM
    1988 300SE wheels Guest (MBNZ) The Discount Tire Direct Tire, Wheel, Brake & Suspension 2 08-29-2006 04:52 AM
    Putting 16 alloys on a 1988 300SE tonycrowe W126 S,SE,SEC,SEL,SD,SDL Class 0 10-20-2002 07:34 AM
    1988 300se coolant leak gogolfing W126 S,SE,SEC,SEL,SD,SDL Class 2 08-18-2002 07:41 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome