New member from Australia-1988 Mercedes Benz 230E (W124) - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 02-14-2009, 11:21 PM Thread Starter
BenzWorld Newbie
Date registered: Feb 2009
Vehicle: 1988 Mercedes Benz 230E (W124)
Location: Australia
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
New member from Australia-1988 Mercedes Benz 230E (W124)

Good afternoon everyone - I'm new and learning to find my way around this helpful site. I used to own a 1982 MB 280 SE (W126) and loved it's smoothness and comfort even at it's old age and mileage- 330 000Kms.

Recently with the increase in the petrol prices and the cars age and cost of spares and repairs I decided to trade it for something smaller, newer and more economical and went for a 1988 230E. It was sold to me by a Mercedes restorer who said he'd replaced the original engine. With the problems I'm having it was obviously in a pretty shoddy mechanical state when I got it, but I think it has potential and want to get it into perfect mechanical condition.

The bodywork of the new car looks great but it seems to have a number of problems that I'm trying to iron out and would appreciate any advice. The first noticeable problem was that the car wandered a little on the road when driving which was very irritating. So I took it to a front end specialist for some advice and they reported that the idler arm bush was worn, the front wheel bearings had slight play and the rear lower trailing arm required replacing. I think I was sold a lemon!

So I've put on new tyres, had the wheels balanced and aligned, had the idler arm and wheel bearings sorted and it's much improved. But recently it's started a new problem. It started idling very inconsistently and missing every now and then, to the point where it stalled every time I tried to pull off when it was cold. The problem seems to get a bit better once it's warmed up a bit. I asked a mechanic friend about it and he recommended checking and replacing the spark plugs and spark plug leads. I have since replaced the plugs and it's starts first time now and is running much more smoothly but occasionally seems to miss again. So it seems new leads might be the next step.

I don't have a huge amount of mechanical experience but can do the basic things so I would appreciate any advice or suggestions.
lespollock is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    w124 230e 1988 a/c wiring diagram derekmcbenz W124 E,CE,D,TD Class 5 01-25-2012 04:10 AM
    1988 Mercedes Benz 300E Banner248 W210 E-Class 1 01-25-2009 01:03 PM
    FS: 1988 Mercedes Benz 300SEL Michael Pillay For Sale/Wanted/Trade/Giveaway 0 04-27-2008 02:23 PM
    Mercedes Benz Show Australia solicit Events 1 09-09-2006 01:27 AM
    Mercedes Benz 230E Pics From Malaysia roy560 W123 E,CE,D,CD,TD,TE Class 10 08-06-2006 07:32 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome