New Member bought a '93 190e 2.3 - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 02-12-2009, 06:08 AM Thread Starter
BenzWorld Member
Date registered: Feb 2009
Posts: 171
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
New Member bought a '93 190e 2.3

Hi all,

Nice forums you have here....lemme start off by saying sorry this is long. I read up on a lot of posts before I bought the 190e I just got. I feel he was a little steep on the price, but damn did it ride soooo smooth. I had a friend that had a mercedes when I was younger and didn't pay attention to how it rode. After driving this little car, I'm going to love it. Think I'll end up putting a couple hundrek k's at least on it. I plan to use it as my daily driver (I live pretty far from work). My quad cab truck was killing me in gas, this should help some.

Anyways about the car, I know it has been in some sort of wreck, I think it was probably just front end damage, the last owner was kinda weird. I didn't want to talk too him much, just get the car, lol. However, it only had 105k on it...for a 93? It was his Sunday driving car...this dude had 7 cars lol. I was impressed from the low miles (I've put 1k on it already in the last week lol, cruising I guess)...and whatever wreck it may have been in, I could not tell from how well it rode. Everything seemed functional except, it looked like the right rear passenger window regulator is out, and the outside temperature sensor is loose or malfunctioning. Other than that I think it is in overall good-great condition. He did put some mercedes rims on it, or at least it has a center cap that fit on it perfectly and looks great. They are 18's lol, they look really good on it and ride better than expected with low profiles. (at least to me)

Well crap...longer than I thought. I love all the good information here...My next step is to replace that crappy JVC cd/radio and speakers that he put in. From what I can tell only the rear speakers work. I'll have to pull the head unit out and see if he used the factory wires or ran his own. I thought the system sounded kind of week from all the other nice aspects of the car. I was like 2 speakers cmon no way...then I looked up on the forums and found it should have 6, which got me excited to replacing them.

Take care...I have more reading/posting to do

Last edited by mtownraider; 02-12-2009 at 06:11 AM.
mtownraider is offline  
Sponsored Links
post #2 of 3 (permalink) Old 02-12-2009, 02:06 PM
BenzWorld Elite
Date registered: Oct 2007
Vehicle: 2002 SLK 230 1986 560SL 2008 Honda CRV
Location: Rochester,NH USA
Posts: 3,664
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Welcome to Benzworld
livefreeordie is offline  
post #3 of 3 (permalink) Old 02-14-2009, 04:48 PM Thread Starter
BenzWorld Member
Date registered: Feb 2009
Posts: 171
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks alot,
I've got a few things I want to do to it, the person before me put some 18's on it and it rubs some...but damn the rims look so good on them (factory mercedes rims), so I'd hate to go back down, especially since I just bought some tires. Off to reading more topics....there sure is a good wealth of knowledge here from over the years
mtownraider is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    New Member - Just bought 1970 250C NewWilOrder General Mercedes-Benz 0 09-11-2008 12:22 PM
    New UK member - Just bought an E55T S2 PTH W210 E50 AMG, E55 AMG 6 04-30-2008 02:13 PM
    Just bought E430 - New member JIM55 W210 E-Class 9 01-10-2007 12:44 PM
    new member; just bought slk32! rbridges R170 SLK-Class 6 11-09-2003 08:49 AM
    Just bought a 420SEL and am new forum member Guest (MBNZ) W126 S,SE,SEC,SEL,SD,SDL Class 1 07-26-2002 07:14 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome