Proud father of 2 300D Benzs saying hi - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 02-02-2009, 11:49 AM Thread Starter
BenzWorld Newbie
jstorz's Avatar
Date registered: Feb 2009
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Proud father of 2 300D Benzs saying hi

Just found your community a few days ago troubleshooting some issues I'm having. Love the place after only looking around a couple dozen threads. I knew the internet rocked but it's seeing niche resources like this that really makes it special.

My 2 babies & their problems

1. '83 300D (4dr) - this thing has run like a champ in the 9 years I've had it. Last Sunday she had problems starting, but after getting cranked up she proceeded to drive 200 miles with no issues. Turned off and on about 5 times that day with no issues.

That night it froze and we got some ice/snow. The next day I had the same problems starting the car but this time it wouldn't work at all. The engine turns over but won't catch (keep idling).

I ordered a block heater cord as it seems my connection is there but I don't have the plugin. I was given one when I bought the car but didn't use it in 9 years and it became lost in the system.

2. '84 300D (2dr) - Prettiest car you've ever seen! But like my other, she has some issues.

This one has issues dying when going up hill (that's bad in my city). It seems that gas is not being delivered because if I coast to flat ground, the car starts up no problem.

I've ordered both fuel filters (suggestion in some threads I've read) and will be changing them out tomorrow. I've considered picking up the kit of diesel purge to help both cars run better ... but my obvious priority is getting one started up ASAP for my daily grind.

Any help / comments are appreciated but keep in mind, I'm a programmer by trade and don't know my way around an engine as I should.

In only 2 days I can tell that I will love this place!! I will keep browsing and posting here.
jstorz is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    MY-BENZS General Mercedes-Benz 1 08-09-2009 10:06 AM
    MY-BENZS General Mercedes-Benz 1 08-09-2009 10:06 AM
    Question between 2 benzs... GFO106 W140 S-Class 11 04-09-2007 09:35 PM
    2x Benzs for 9k 83' 300d turbo & 90 300te doucy2 For Sale/Wanted/Trade/Giveaway 0 09-20-2006 03:02 PM
    Proud new owner of a white '82 300D! Trans Ques though... carmine615 W123 E,CE,D,CD,TD,TE Class 5 08-21-2006 08:48 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome