1999 E320 using excessive oil - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 02-02-2009, 11:27 AM Thread Starter
BenzWorld Newbie
Date registered: Feb 2009
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
1999 E320 using excessive oil

My 1999 E320 engine has 115,000 miles and it started using oil excessive oil around 90,000 miles. I am the original owner and always had the vehicle in for proper servicing. When using the vehicle on long trips (750+ miles) the low oil light indicator would light up and checking the dip stick showed that the oil was at the low level. The engine started to use about 1.5 quarts every 1200-1500 miles. Up until recently there was no indication of an oil leak (no oil spots on the garage floor or around the engine.)
On my last trip I topped off the oil and just after 750 miles the oil light indicator went on. At this time, there were oil drops on the garage floor and there was oil leak just under the fan belt assembly. I had it serviced with new seal rings and sealant. But, does this engine use oil at the rate of 1.5 quarts every 1500 miles? That seems excessive.
P Chuck is offline  
Sponsored Links
post #2 of 3 (permalink) Old 02-03-2009, 04:56 PM
BenzWorld Newbie
Date registered: Feb 2009
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Hello I'm Larry a new member. I have a 2000 E320 any mine uses about 2 quarts at 1600 miles. I have no drips or leaks and no tail pipe smoke. Mine has 196,000 miles and I'm concerned.
LarryHof is offline  
post #3 of 3 (permalink) Old 02-03-2009, 06:31 PM Thread Starter
BenzWorld Newbie
Date registered: Feb 2009
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Excessive Oil use on 1999 E320

It appears that many owners are reporting similar oil use. No leaks and no oil smoke from the exhaust. Does anyone know whether there was a design flaw with the rings where oil is blowing out of the engine, but not burnt oil where blue smoke would be a tell tale sign? My engine is still getting 29 mpg on the highway and 23 in town. The engine is not running hot, but is consistent, just below the 80 degree C marker.
P Chuck is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Excessive clatter in E320 CDI? daduca W211 E-Class 26 03-11-2012 12:01 PM
    1999 E320 oil change question woodnut W210 E-Class 11 09-23-2004 09:13 PM
    Excessive Oil consumption on ML jloreto99 W163 M-Class 15 07-13-2004 10:23 AM
    1999 E320 Air and Oil Filters...please help DaveE320 W210 E-Class 0 07-03-2004 12:01 AM
    Excessive oil usage Dave W163 M-Class 2 02-07-2002 03:33 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome