190e Automatic Question - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 01-31-2009, 11:26 AM Thread Starter
BenzWorld Newbie
Date registered: Dec 2008
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
190e Automatic Question

Hello, I just installed a 722.400 automatic in my 1993 190e. I have attached everything as it was before tearout. Problem is now transmission feels like someone is applying a brake when I use reverse. On jack stands the drive line spins freely when in netrual, but as soon as it is put in reverse the transmission feels like an internal brake is being applied. Forward seems fine and will go down the highway at any speed.

New fluid, linkage is adjusted, drive shaft spins freely in netrual, nothing touching drive train, vaccum hoses connected.

Any clues?
National98 is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    86 190E 5 speed to 88 190E automatic engine swap Benz Sage W201 190-Class 13 07-21-2008 08:20 AM
    190E 2.5-16v Automatic hambleford W201 190-Class 1 10-09-2006 01:13 PM
    Wiring diagrams for 190E 2.6 automatic adtwins W201 190-Class 4 07-19-2005 07:56 AM
    190E 2.3-16V Automatic??? jjazac W201 190-Class 4 03-09-2005 02:48 PM
    Looking for 190E 2.3-16 Automatic Guest (MBNZ) W201 190-Class 6 02-07-2002 01:22 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome