regarding unknown C230 K leak - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 01-31-2009, 10:26 AM Thread Starter
BenzWorld Junior Member
 
Kotodama's Avatar
 
Date registered: Jan 2009
Vehicle: C230 Kompressor
Location: DFW
Posts: 15
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
regarding unknown C230 K leak

Last week I received replies about a leak beneath my C230 K that suggested it was an electrical AT connector. I'm not dismissing that suggestion. However the weather was good enough to take a look underneath today. I didn't get a great view of the connector because I didn't have very good access. Perhaps if I describe what I did see one of you could respond.

There is a metal plate beneath the transmission. There is a small hole drilled into that plate. The mystery liquid is leaking from that hole. The liquid is greenish and has a nondescript "mechanical" smell. Any further ideas? Could it be a leaky cooling line? OR do you stick with the AT electrical connector solution? That plate seems to be bolted in; will it come off easily? I just pray it isn't one of those mega expensive fixes!
Kotodama is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 02-02-2009, 09:08 PM
BenzWorld Member
 
RoadsideDude's Avatar
 
Date registered: Mar 2008
Vehicle: 2008 R350
Location: Greenville, SC
Posts: 67
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
WHAT YOU'RE DESCRIBING IS THE TRANS ELECTRICAL CONNECTOR LEAKING, which is common for the 202 chassis, which is what car you have. That little plate comes off and the connector is under that plate on the front corner of the trans; I dont know what your mileage is, but will tell you thats a common problem for your car. I recomend you take it to a mechanic who knows about Benz cars; if you dont remove the connector correctly, the pin bolt will shear off and you'll be putting in a valve body in your trans, and that will be EXPENSIVE, iF YOU HAVE ANY DOUBTS ABOUT ANYTHING, then consult with someone who works on Benz cars, Take care, Ron

RoadsideDude is offline  
post #3 of 8 (permalink) Old 02-03-2009, 12:00 PM Thread Starter
BenzWorld Junior Member
 
Kotodama's Avatar
 
Date registered: Jan 2009
Vehicle: C230 Kompressor
Location: DFW
Posts: 15
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Ron

Thank you very much. I love the photo!

What your suggesting has been the consensus of opinion. I put my car on jacks, took off the plastic protection plate and saw the electrical connector behind the metal plate. I was able to verify that the fluid was coming from the connector. I decided to take it to a qualified mechanic at that point (mainly because I was concerned the whole car would come down on me)

Thanks again for your input.
Kotodama is offline  
post #4 of 8 (permalink) Old 02-04-2009, 07:46 PM
BenzWorld Junior Member
 
joedrt99's Avatar
 
Date registered: Nov 2008
Vehicle: 2003 c230 kompressor
Location: Albany, NY
Posts: 37
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Kotodama View Post
Last week I received replies about a leak beneath my C230 K that suggested it was an electrical AT connector. I'm not dismissing that suggestion. However the weather was good enough to take a look underneath today. I didn't get a great view of the connector because I didn't have very good access. Perhaps if I describe what I did see one of you could respond.

There is a metal plate beneath the transmission. There is a small hole drilled into that plate. The mystery liquid is leaking from that hole. The liquid is greenish and has a nondescript "mechanical" smell. Any further ideas? Could it be a leaky cooling line? OR do you stick with the AT electrical connector solution? That plate seems to be bolted in; will it come off easily? I just pray it isn't one of those mega expensive fixes!
kotodama...what yr and how many miles you have??
joedrt99 is offline  
post #5 of 8 (permalink) Old 02-04-2009, 08:57 PM Thread Starter
BenzWorld Junior Member
 
Kotodama's Avatar
 
Date registered: Jan 2009
Vehicle: C230 Kompressor
Location: DFW
Posts: 15
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
It's a 2003 with 70K. Do you have the same problem?
Kotodama is offline  
post #6 of 8 (permalink) Old 02-04-2009, 09:01 PM
BenzWorld Junior Member
 
joedrt99's Avatar
 
Date registered: Nov 2008
Vehicle: 2003 c230 kompressor
Location: Albany, NY
Posts: 37
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
i have an 03 with 65,000 on it...f*ck that means all i have to do it wait...haha
joedrt99 is offline  
post #7 of 8 (permalink) Old 02-04-2009, 09:08 PM Thread Starter
BenzWorld Junior Member
 
Kotodama's Avatar
 
Date registered: Jan 2009
Vehicle: C230 Kompressor
Location: DFW
Posts: 15
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Don't worry too much. Mines in the shop now. It's a $120 fix. Enjoy happy motoring in the meantime!
Kotodama is offline  
post #8 of 8 (permalink) Old 02-04-2009, 09:22 PM
BenzWorld Junior Member
 
joedrt99's Avatar
 
Date registered: Nov 2008
Vehicle: 2003 c230 kompressor
Location: Albany, NY
Posts: 37
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
thanks...finally something that doesnt cost at least $500 to fix!! but yah ill keep it gangster fo' sho'
joedrt99 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    unknown leak Kotodama W202 C-Class 11 01-29-2009 07:31 PM
    slow leak from unknown part on top of radiator matt123 C216 CL-Class 0 10-12-2008 04:53 AM
    Unknown Fuse box and Unknown resistor Chadahar W126 S,SE,SEC,SEL,SD,SDL Class 4 09-15-2008 08:29 AM
    Unknown wire hanging from underneath my '98 c230 Sonic-C W202 C-Class 1 09-24-2007 07:26 AM
    small leak from unknown source pondscum007 W123 E,CE,D,CD,TD,TE Class 1 03-31-2003 10:42 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome