Blower motor trouble - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 01-28-2009, 08:38 PM Thread Starter
BenzWorld Newbie
Date registered: Jan 2009
Vehicle: 1990 300te
Location: michigan
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Post Blower motor trouble

I just picked up a 1990 300 te and the blower motor doesn't come on even after letting the car get completly up to operating temp. Any ideas on where to look first? It gets rather cold in northern Michigan

Last edited by yamifrk; 01-28-2009 at 08:51 PM.
yamifrk is offline  
Sponsored Links
post #2 of 5 (permalink) Old 01-30-2009, 11:39 AM
BenzWorld Elite
tuttebenne's Avatar
Date registered: Jul 2005
Location: Long Island
Posts: 3,376
Mentioned: 3 Post(s)
Quoted: 208 Post(s)
Blower motor failures are quite common in the 124. The likely cause is the regulator which is mounted under the motor, which is under the wiper assembly. But first you want to check the easy stuff:
- check the fuse that is for the heater; the fuse is found in the fusebox,
- check the blade fuse which is located in the engine compartment. It is concealed within a black plastic box that is maybe 3/4 of an inch wide by two inches long. The box is mounted over the driver's front wheel arch and has a wire going into it from the left and from the right sides. This fuse should be taken out and inspected because they can be cracked and not visible if you haven't dealt with them before.

There are multiple threads here that will walk you through the process if these two simple checks don't yield the cause of your blower motor problem.

'89 300E
'90 300CE
'93 400E
'93 500E
'00 E320
'73 Alfa GTV
'77 308GTB
tuttebenne is offline  
post #3 of 5 (permalink) Old 10-19-2011, 03:06 PM
BenzWorld Junior Member
Date registered: Aug 2011
Posts: 25
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
multiple threads

Does anyone know where I can find the multiple threads on replacing my blower motor on my 1988 300 TE ? Any help would be greatly appreciated. Thank You Mark
drumhead87m is offline  
post #4 of 5 (permalink) Old 02-13-2012, 06:44 AM
BenzWorld Junior Member
Date registered: Aug 2011
Posts: 25
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Thanks YOU tuttebenne for the reply ......drumhead87m
drumhead87m is offline  
post #5 of 5 (permalink) Old 02-13-2012, 08:59 AM
Administratoris Emeritus
GeeS's Avatar
Date registered: Aug 2002
Vehicle: 2021 SL770
Location: Fountain Hills, AZ
Posts: 44,831
Mentioned: 1 Post(s)
Quoted: 544 Post(s)
I would peruse the W124 section.

"If spending money you don't have is the height of stupidity, borrowing money to give it away is the height of insanity." -- anon
GeeS is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    1998 W210 E300DT Bad Blower Regulator or Blower Motor?? How to tell DieselNuts W210 E-Class 12 08-16-2012 09:32 AM
    blower motor jmoney6 W124 E,CE,D,TD Class 6 03-04-2008 12:21 PM
    Blower Motor Help Please N1ML W163 M-Class 4 10-12-2005 07:42 PM
    Blower Motor Help Please N1ML W163 M-Class 0 10-11-2005 04:21 PM
    Wiper Motor or Blower Motor / Resistor Pack Failure?? jangr320 W163 M-Class 3 11-13-2004 11:20 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome