Hello - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 01-25-2009, 09:54 AM Thread Starter
BenzWorld Newbie
Date registered: Jan 2009
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)

Hello everyone,

I am new to this forum and in ownership of an 1988 MB 190E in Midnight Blue. I bought the car and am working on getting it on the road. I live in NC in a rural area and am an administrator at a community college. My car will start up and run if the temperature is around 50 degrees. It will only run about 20 minutes and then stop. It may or may not start again. The fuel line has been disconnected when it won't start and the fuel pump will spray a stream 20 or so feet.

I took it to a mechanic that said that it is the Ignition Control Module. I don't know. I have been reading the threads and see that it could be a myriad of problems. I was hoping that I could get some ideas before I start throwing money at the problem(s). I have located a junk yard that has several 190's and am compliling a list of items to pull. I would appreciate anh ideas, help, or feedback with these issues.
dorvic is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome