Gear box fault.....please help - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 01-20-2009, 10:15 AM Thread Starter
BenzWorld Newbie
 
Date registered: Jan 2009
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Unhappy Gear box fault.....please help

Hi all I'm the owner of a c220 cdi elegance estate which has a 6 speed sequetronic gearbox. It's done 140K it's an 02 plate. It has a full MB service history. Recently it has started playing up by not wanting to stay in automatic mode. It will only stay in auto on the first drive of the day when cold. After that it will switch to the gears with no warning. The gears are smooth and it doesn't seem mechanical. We were told by one garage it would need new gearbox £3000!! but I took the bull by the horns and rang a Mercedes dealer and they said it could be the gearbox relay. Has anyone come across this problem themselves and is it a straight forward job to repair, and here's the worst bit how much is it likely to cost. They want £100 to diagnose. We want to sell it so have no choice but to get it sorted. They're lovely cars but my god they don't half burn a hole in bank when they go wrong. Car doesn't seem to appreciate there's a credit crunch going on.

Last edited by millymolly; 01-20-2009 at 10:15 AM. Reason: speeling mistake
millymolly is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 01-22-2009, 10:32 AM
BenzWorld Elite
 
iluvjesus's Avatar
 
Date registered: Jan 2009
Vehicle: 210.065
Posts: 2,947
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Smile

Could it be transmission fluid overheating only?

iluvJESUS
"I am the Alpha and the Omega," says the Lord God,
"who is, and who was, and who is to come, the Almighty." Revelation 1:8
iluvjesus is offline  
post #3 of 3 (permalink) Old 01-22-2009, 11:27 AM Thread Starter
BenzWorld Newbie
 
Date registered: Jan 2009
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
We've had a diagnosis today at the dealership and it's saying the lateral acceleration sensor needs changing do you know whereabouts it's located and do I need to have sensor reset after fitting.
millymolly is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Electrical Fault in Fuse Box 230Terry W210 E-Class 4 10-14-2008 01:40 PM
a170 cdi auto box fault please help wiggi28 W168 A-Class 2 03-20-2008 03:23 AM
v280 auto box fault nail it V-Class 2 11-10-2007 10:49 AM
Auto Gear Box Fault....i Think! Smifster V-Class 3 12-12-2006 08:59 AM
5 gear box on my 300D - what type of box? Konijiro W123 E,CE,D,CD,TD,TE Class 8 11-06-2006 12:14 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome