Charging - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 01-19-2009, 06:35 PM Thread Starter
BenzWorld Junior Member
deep3175's Avatar
Date registered: Jan 2009
Vehicle: 95 benz E320 wagon
Location: SC
Posts: 39
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)

I have a 86 benz 300e and I just had the alternator rebuilt and it was fine and now after driving for awhile the anti lock brakes light comes on and the battery dies. I haven't check the starter connection yet but everything visually looks ok. And how do I adjust the belt tension I cleaned all the terminals and drove it around disconnect the negative lead and it still ran fine, but the belt would squeal every once in a while

Last edited by deep3175; 01-20-2009 at 04:53 PM.
deep3175 is offline  
Sponsored Links
post #2 of 2 (permalink) Old 01-27-2009, 08:39 AM
BenzWorld Newbie
Date registered: Jan 2009
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
I can't believe how similar our problems are. Same car, same year, same symptoms, except that I'm in New Haven, CT. My garage couldn't find any problem, but with a rebuilt alternator and new battery, my car has died twice without warning, but is OK for a while after a jump start or battery recharge. If you want to exchange email names, if we find a solution, we can share Rayosun at
Rayosun is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Need help charging AC glendell Vintage Mercedes-Benz 5 09-09-2007 09:34 PM
    charging the AC ldshull Vintage Mercedes-Benz 3 07-18-2006 06:41 AM
    Turbo Charging G=JeepKiller G-Class 19 03-29-2006 07:26 PM
    system not charging help!!! LBC500SEL W140 S-Class 1 06-04-2005 10:47 AM
    Charging a c RedFar W201 190-Class 0 05-06-2005 01:37 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome