Battery keeps dying - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 01-19-2009, 12:35 PM
BenzWorld Newbie
 
Date registered: Jan 2009
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Battery keeps dying

I have a 560sl from 1988 that's battery dies very often like within a month. It isn't used much maybe once a week as just like a fun car. I'v changed the battery, tried charging it and, other things but it continues to die any idea as to what may be causing this problem and if possible a way to fix it on my own would be great.
DARKreaction is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 01-19-2009, 02:02 PM
MTI
BenzWorld Elite
 
MTI's Avatar
 
Date registered: Aug 2002
Vehicle: '85 2.3-16 '99 C280 '11 GLK350
Location: Scottsdale, Arizona, USA
Posts: 4,805
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Each time a standard car battery completely discharges, it loses some ability to recharge and hold a charge.

Battry drains are typically caused by:

1) Bad Battery

2) Bad Alternator or Voltage Regulator not charging the battery

3) An electrical fault that is not switching off with the ignition key draining the battery.
MTI is offline  
#3 (permalink) Old 01-19-2009, 02:19 PM
BenzWorld Newbie
 
Date registered: Jan 2009
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
it might be a short.. its not a bad battery and i'm fairly certain the regulator and the alternator are working properly. How would I find a short?
DARKreaction is offline  
#4 (permalink) Old 01-19-2009, 02:27 PM
MTI
BenzWorld Elite
 
MTI's Avatar
 
Date registered: Aug 2002
Vehicle: '85 2.3-16 '99 C280 '11 GLK350
Location: Scottsdale, Arizona, USA
Posts: 4,805
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
You'll be checking for voltage with a volt meter at the fuse block, focusing on the circuits that should be "dead" when the ignition is keyed off.

Just curious, but why are you so certain about the alternator or voltage regulator, which are "usual suspects" in any dead battery/improper charging scenario?
MTI is offline  
#5 (permalink) Old 01-23-2009, 09:36 PM
BenzWorld Newbie
 
Date registered: Nov 2006
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by DARKreaction View Post
I have a 560sl from 1988 that's battery dies very often like within a month. It isn't used much maybe once a week as just like a fun car. I'v changed the battery, tried charging it and, other things but it continues to die any idea as to what may be causing this problem and if possible a way to fix it on my own would be great.
you could put a trickle charger on it to keep it charged up,
or get an Amp meter and check the draw on the battery,put it between the batt cable and post,key out,make sure your doors,hood and trunk switch is closed and check for a draw, anything under 30ma on that car is ok..
if its high you can pull fuses out and see which fuses lowered the reading,or disconnect some things..sometimes the alt. will put a drain on it,also the antenna motor was known to put a drain on the battery also back then..
BenzTek510 is offline  
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Help on Complete chaos during battery dying masterninja R129 SL Class 4 03-12-2008 01:53 PM
Battery Dying AdamNEUK W163 M-Class 5 02-21-2007 04:36 AM
help!!! battery dying joselorenzo W126 S,SE,SEC,SEL,SD,SDL Class 11 09-17-2006 08:13 PM
Battery dying taranch W124 E,CE,D,TD Class 5 12-10-2004 11:51 PM
battery keeps dying and slow starts mbnz3993 R230 SL Class 1 01-15-2004 09:31 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome