92 500sl r129 - front is sitting on the ground - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 01-19-2009, 11:16 AM Thread Starter
BenzWorld Junior Member
Date registered: Jun 2006
Posts: 11
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
92 500sl r129 - front is sitting on the ground

I have a 92 500sl R129, the car was sitting for about 2 years and I recently replaced a lot of things before starting her up again that I knew needed replacing. I also replaced the front suspension "spheres" that connect to the hydraulic auto leveling suspension, I think it's called ASR or something like that?

The car has always had issues with the front sitting too low, so after all the work i start her up and everything is working fine except for the suspension. The front is sitting as low as it possibly can, I let the car run for a good 1 hour thinking it might bleed the air out, i tried to bleed it at the pump and at the front spheres. Still no luck.

A few things to note:

* pump is working, bleeding at the pump results in lots of fluid coming out and onto the ground. Doesnt shoot out with high pressure though, more like "burps".

* When attempting to bleed at the spheres, i get almost no fluid, just a tiny bit comes out and thats it, then no more than drip drip drip

* The return line to the reservoir looks like nothing is coming out of it. I might be wrong, but isnt the return line supposed to constantly have something coming out of it back into the reservoir?

Any suggestions? Any links or writeups that might help?

baktasht is offline  
Sponsored Links
post #2 of 2 (permalink) Old 01-20-2009, 12:59 PM Thread Starter
BenzWorld Junior Member
Date registered: Jun 2006
Posts: 11
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
I've checked the actuators. The rear one looks fine. The front one looks fine, but the arm is not connected to anything. What position should it be in?

Also, should the pump be spraying out at high pressure when i disconnect the hose at the pump, or just dribbling out? Mine just dribbles.
baktasht is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    500SL (R129) --> SL 55 (R129) 500 + hp EST-R129 R129 SL-Class 43 03-25-2011 01:41 AM
    R129 - 91' - 500Sl - 500 HP Q? StuartKnight R129 SL-Class 8 12-01-2007 10:05 AM
    W124/R129 500E/500SL front calipers & rotors M104-AMG For Sale/Wanted/Trade/Giveaway 0 08-12-2007 07:45 PM
    front windows not sitting flush 78-450 slc R/C107 SL/SLC Class 9 05-05-2007 04:03 AM
    R129 500SL Parts Wanted gorfllub For Sale/Wanted/Trade/Giveaway 0 02-13-2007 02:31 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome