Hello everyone from the UK - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 01-12-2009, 03:09 PM Thread Starter
BenzWorld Newbie
Date registered: Jan 2009
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Hello everyone from the UK


I have just gone from a 1989 190e merc to a 500 sec from 1984. I don't know why I bought it, but I wanted a big Merc and this came up! I think it looks great and it seems to be in good order. Perhaps its misfiring but I can't tell, it seems a tad lumpy sometimes.

Anyway I am living in Harrogate, North Yorkshire, UK.

Anyone else who lives nearby or has an SEC please say hi! and anyone else!
Attached Thumbnails
Click image for larger version

Name:	008a.jpg
Views:	31
Size:	192.3 KB
ID:	215212   Click image for larger version

Name:	009a.jpg
Views:	27
Size:	195.2 KB
ID:	215213  
strangehighways is offline  
Sponsored Links
post #2 of 3 (permalink) Old 01-13-2009, 07:56 AM
BenzWorld Junior Member
Date registered: Jan 2009
Vehicle: 1957 219 W105 , 1963 220S W111 , 1984 190E W201 , 1986 500SEL W126 , 1987 190E 2.6 W201
Location: Glasgow , Scotland
Posts: 16
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Hi , I'm in Ayrshire and I have a couple of 190's plus a 500SEL . You can see some pics of my cars in the thread 'Hello' a dozen or so below this one

Your car looks very nice !


Derek .
Pontoneer is offline  
post #3 of 3 (permalink) Old 02-02-2009, 10:50 AM
BenzWorld Junior Member
Date registered: Dec 2007
Vehicle: W123.230TE W126 SEC 500, MG MIDGET, MORRIS MINOR
Posts: 18
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Hi there
I have a SEC 500 in black and live in Leeds W yorks. Funnily enough mine was also lumpy. You can tell because it actualy sounds like an American V8. I removed the distributor cap which had not been off in years by the look of it. The segments were burnt. I will replace the plugs too. I am sure this will cure the old gal.
What other problems have you got ?
A7RONU is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome