Sensor problems - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 01-11-2009, 04:12 AM Thread Starter
BenzWorld Newbie
 
Date registered: Jan 2009
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Sensor problems

Hi, i have a c200 kompressor which keeps showing an open engine bonet malfunction but bonet is closed any clues and also when starting the engine there is a clicking noise which lasts a few seconds is this the climate control or something more sinister?
toothnurse is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 01-11-2009, 06:42 AM
BenzWorld Elite
 
Diesel Benz's Avatar
 
Date registered: Dec 2005
Vehicle: 222.132 & 221.122 & 212.025 & 906.633
Location: Europe
Posts: 10,322
Mentioned: 3 Post(s)
Quoted: 34 Post(s)
Quote:
Originally Posted by toothnurse View Post
Hi, i have a c200 kompressor which keeps showing an open engine bonet malfunction but bonet is closed any clues and also when starting the engine there is a clicking noise which lasts a few seconds is this the climate control or something more sinister?
The bonnet open warning must come from the switch that detects if the bonnet is open (part of the alarm system). An E-class owner had a similar issue recently. You would have to check that the switch is operating properly. It could be the switch itself or the mechanical adjustment for the switch or a wiring/connector issue.

The engine noise could be almost anything. I'd guess valve lifters. When did you change oil last time and what kind of engine oil do you have?
Diesel Benz is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Oil Level sensor problems?? jskins2000 W203 C-Class 3 09-21-2008 12:09 AM
    Change of Fuel / O2 Sensor problems oztds R170 SLK-Class 4 02-07-2007 03:11 AM
    Weird noise and sensor problems bronze560SEL W140 S-Class 0 09-27-2004 04:05 AM
    Rain-sensor problems JQ General Mercedes-Benz 5 01-12-2003 10:39 AM
    MAS sensor can cause LOTS of problems! (more) Dennis (Boston area) R170 SLK-Class 4 02-27-2002 06:04 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome