SL 500 combi instrument problem - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 12-29-2008, 04:50 AM Thread Starter
BenzWorld Newbie
 
Date registered: Dec 2008
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
SL 500 combi instrument problem

The combi instrument unit of my SL 500 has suddenly stopped working. i.e. speedo, petrol gauge, temp gauge etc. All the bulbs don't work (not illuminating when ignition switched on). Only the airbag light comes on.

I have checked the fuses, dis and re connected the battery but looks like I need to take it the garage for diagnostic computer.

Wondering if anyone had any ideas before going down the expensive route.

Thanks in advance
Lynne9375 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 12-29-2008, 08:00 AM
BenzWorld Elite
 
Diesel Benz's Avatar
 
Date registered: Dec 2005
Vehicle: 222.132 & 221.122 & 212.025 & 906.633
Location: Europe
Posts: 10,322
Mentioned: 3 Post(s)
Quoted: 34 Post(s)
I'm not familiar with this car and this issue but I would check that the cluster ground wiring is fine as well as the power. If all go at once, it would hardly be something else (assuming you already checked the correct fuses).

I see you posted the question at Audio & Telematics, fine, but I'd try on the SL forum too if you don't get help (is it a 129 or 230?).
Diesel Benz is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    e36 AMG engine in e320 combi? Sebastiaan General AMG 9 05-11-2009 04:24 PM
    e36 AMG engine in e320 combi? Sebastiaan W124 E,CE,D,TD Class 5 10-28-2008 12:41 PM
    Wanted W126-500 Euro Instrument Panel hankjay For Sale/Wanted/Trade/Giveaway 0 01-24-2008 05:52 PM
    c 220 diesel combi instrument problem gudikcik W202 C-Class 0 03-30-2006 05:36 PM
    98' C250 TD Combi - documentation dan_garleanu W202 C-Class 0 06-21-2005 03:41 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome