Wiper arm problem, E320 - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 12-20-2008, 12:53 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Dec 2008
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Wiper arm problem, E320

My wife has a 2000 e320. I just got a new wiper blade and put it on, and now the wiper arm is stuck in a raised position and will not go back down to contact the windshield. I had thought it would sort of snap back into position with some pressure, but I can tell that if I push any harder, I will damage or break it.

I can't find any release button or anything to lower it. Ack!

The thing is pointing at about a 25 degree angle up from the glass and seems to be locked in that position. How do I release it?

Thank you for any help you can offer me, very much.
waynevan is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 12-20-2008, 02:12 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Dec 2008
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
The arm went down by pushing harder, but it was a heckuva lot more pressure than I would have expected, I was seriously worried it was going to bend or break. That's crazy.
waynevan is offline  
post #3 of 6 (permalink) Old 12-20-2008, 07:12 PM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Lifetime Premium Member
That's a common "problem" with these monowiper arms. Us fellow W210 owners would have explained that if you had been more patient, or posted your problem on our model-specific forum. With that said, I'm glad you resolved the issue.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
post #4 of 6 (permalink) Old 12-20-2008, 07:26 PM
Lifetime Premium Member
 
e-420's Avatar
 
Date registered: Sep 2008
Vehicle: 1997 E-420 (150K miles), 1997 SL500, (90K miles) 2015 GMC Sierra Denali 2500HD CC/SB/4x4 Duramax
Location: Portland, OR
Posts: 3,363
Mentioned: 13 Post(s)
Quoted: 360 Post(s)
Lifetime Premium Member
Had the same problem. Diagnosed it as the springs holding the arm down get trapped when the arm goes to far up. Solution was to use a pick to push the spring into the correct position. Hard to describe, but if you experience the problem it becomes evident when you look at the spring assy under the arm. I'm sure others have a better explaination.


--------His------------Hers-------

97 SL500 Imperial Red
/Parchment Leather/Black Top


Chromed OEM wheels, Akebono's, H1+90 fog, Burlwood/Leather shift knob, Rostra Lumbar support, Check seat heaters, Bilstein's, Parrot Bluetooth, GG Bailey Custom cargo mat, GG Bailey trunk mat, Real Burlwood Instrument Cluster w Chrome rings, Burlwood & Chrome shift surround, Euro headlights with Osram 70W/65W H-4's, clear corners, Silverstar corner lamps, Euro Trunk mount Warning triangle, SL600 Burlwood armrest trim & Burlwood cupholder sliding cover, Kahtec flashing third brake light (CHMSL)


97 E420 Royal Indigo/Grey Leather

Raintracker wiper, Rostra Lumbar support, Parrott Bluetooth, 17" chrome AMG replica wheels, Bilstein's, Akebono's, smoked marker lights, Osram 65W H7's, H1+90 fog, Rear Seat Child restraint Tether, Burlwood/Leather shift knob, OEM Mudflaps, DRL's, Becker Aux input
e-420 is offline  
post #5 of 6 (permalink) Old 12-21-2008, 04:42 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Dec 2008
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by Musikmann View Post
That's a common "problem" with these monowiper arms. Us fellow W210 owners would have explained that if you had been more patient, or posted your problem on our model-specific forum. With that said, I'm glad you resolved the issue.
Heh heh. It wasn't actually impatience on my part so much as I found out the answer elsewhere. My wife was sleeping when I first posted the question, and when she got up, I explained to her my predicament and she said, "Oh, that happened to me too and I just pushed it even harder".

When she saw the surprise on my face she told me it was sleeting on her and she couldn't drive like that anyhow, so it was either break it or fix the dang thing but either way she wasn't going to stand out there in the inclement weather putzing around with it.

You have forced a confession out of me Musikmann, I wasn't going to mention that part.

Edited to add; Wow! I just signed up, so forgive me but I didn't scroll down far enough to see the model specific forums. This place is a gold mine.

Last edited by waynevan; 12-21-2008 at 04:46 AM.
waynevan is offline  
post #6 of 6 (permalink) Old 07-23-2012, 12:07 PM
BenzWorld Junior Member
 
Date registered: Jul 2012
Vehicle: 2001 E320
Location: Atlantic City New Jersey
Posts: 15
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Same thing happened 2 me.E320 first time washing the car wiper would not go back down.wd 40 in the spring area and she came back down...
e class man 1 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    E320 wiper arm help jmcquellon W210 E-Class 10 03-05-2011 09:08 AM
    WTB: W126 Euro Headlamp Wiper Motor/Wiper Arm cyberdyne For Sale/Wanted/Trade/Giveaway 1 02-07-2007 02:24 PM
    Wiper Arm Problem....wife messed it up...any Help?? AFARR W201 190-Class 9 01-26-2006 03:57 PM
    correct 'parked' position for '97 E320 wiper arm? xzz2343 W210 E-Class 2 10-02-2005 02:56 PM
    1995 C200 single arm wiper problem IanMerc W202 C-Class 2 02-23-2005 05:08 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome