Hello all - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 12-20-2008, 03:48 AM Thread Starter
BenzWorld Newbie
Date registered: Dec 2008
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Hello all


This is my first Mercedes. I am currently living in Germany so reading the user manual in German is challenging. Below is my car specifications:

Model: W203, C200 kompressor

Year: Dec 2001

Mileage: 69,000km (~43,000 miles)

Type: Station Wagon

Transmission: Manual, 6 speed

The car is very powerful and fun to drive. However, there are some noise from the power steering (i think the PS fluid is low) - yet to check. Second gear shits "stiff". other than that, i am very happy with the car.
szepinn is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome