URGENT! heater issues!!! - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 12-15-2008, 02:52 PM Thread Starter
BenzWorld Member
 
Date registered: Jan 2008
Vehicle: 99 c230k
Location: lethbridge
Posts: 171
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
URGENT! heater issues!!!

Okay, so went in my car today, and turned on the heater fan, and no air is coming out, I checked the fuses, and everything there seems okay, Im leaving for a 10 hour drive in the morning and its -30 celsius. What could this be, last time i was in the car, it worked fine, it got real cold, and now its doing this?? Any suggestions?!

p.s. sorry for having to post on this forum as well as my w202 forum(pretty dead), but I just need some help right away!
chong188 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 12-15-2008, 03:09 PM Thread Starter
BenzWorld Member
 
Date registered: Jan 2008
Vehicle: 99 c230k
Location: lethbridge
Posts: 171
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
nvm, for whatever reason, after getting in the car one more time and turning the dial with fingers crossed, the damn thing started blowing, there is a god after all.
chong188 is offline  
post #3 of 5 (permalink) Old 12-16-2008, 12:07 AM
BenzWorld Elite
 
Diesel Benz's Avatar
 
Date registered: Dec 2005
Vehicle: 222.132 & 221.122 & 212.025 & 906.633
Location: Europe
Posts: 10,322
Mentioned: 3 Post(s)
Quoted: 34 Post(s)
Quote:
Originally Posted by chong188 View Post
nvm, for whatever reason, after getting in the car one more time and turning the dial with fingers crossed, the damn thing started blowing, there is a god after all.
I hope you already did the trip and it was OK. But before doing another one at that temperature, I would check the car. Perhaps the heater blower motor or brushes, the switch or the regulator (perhaps just resistors on this car, then it should be fine at full speed).
Diesel Benz is offline  
post #4 of 5 (permalink) Old 12-18-2008, 10:54 AM
BenzWorld Junior Member
 
Date registered: Feb 2003
Posts: 49
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Family member had a case where over night in freezing temps her heater fan would fail to run for the morning ride to work. Turns out water from melted snow/ice sitting in the well at the base of the windsheild would leak down into the fan housing and then re freeze overnight. The next morning the fan would litterally be frozen and fail to run till the ice melted. Could be a similar issue.
TW10 is offline  
post #5 of 5 (permalink) Old 12-18-2008, 11:16 AM Thread Starter
BenzWorld Member
 
Date registered: Jan 2008
Vehicle: 99 c230k
Location: lethbridge
Posts: 171
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
yah ive made the trip on tuesday and nothing but heat and since the re-start up on monday evening there hasnt been an issue yet. Blame Canada.
chong188 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    URGENT! heater issues!!! chong188 W202 C-Class 6 12-16-2008 06:05 PM
    Heater/ AC Issues dodgethis9271 W124 E,CE,D,TD Class 4 03-11-2007 07:42 PM
    Heater issues, please someone help 240Dbio W123 E,CE,D,CD,TD,TE Class 6 01-31-2007 09:06 PM
    Urgent advice requested on 5 issues -- newbie 500 SE owner Rollingstone W126 S,SE,SEC,SEL,SD,SDL Class 4 06-23-2005 04:03 PM
    Heater Issues Dudas35 W126 S,SE,SEC,SEL,SD,SDL Class 6 03-21-2005 12:41 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome