E320 CDI estate 2001 avantgarde..thumping noise - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 12-14-2008, 05:08 PM Thread Starter
BenzWorld Newbie
Date registered: Dec 2008
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Question E320 CDI estate 2001 avantgarde..thumping noise

Hi Does any one have any strange noises coming from the back of the w210 estate when going over uneven surfaces or speed bumps.

I have removed everything from the back including the spare wheel..tools etc...and still get a 'thumping' noise when going over speed bumps.

I have checked under the car and removed a few stones from the plastic caping under the rear wishbones...and that reduced the 'tinging' noise but i still have the thumping...
...having looked under the seats the battery is bolted in tight and on the rear passenger side there is a module of some sort that is also tightly fixed...

...I suspect it is coming from under the module ...as when I reach under the car there is a 6 inch space between the floor under the read passenger seat and the under side of the car...I think there is something dislodged in that space but have no idea of telling what it could be.

The rear suspension is all very tight and there is no unsual noise from the shocks etc.??

mines not a seven seater and I even tried removing the rear boot flooring panels but its still making the annoying noise.!

Anyone else with a similar noise?


r11pak is offline  
Sponsored Links
post #2 of 3 (permalink) Old 12-14-2008, 05:37 PM
BenzWorld Member
Date registered: Dec 2008
Vehicle: ml430
Location: east bum fudge
Posts: 82
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
even if the shocks are tight they still might be making the noise ive seen it before. the make a thumping sound over bump. its the seals inside that alow fluid to pass leting the stops bottom. how many miles and how old? it may be time for a new set.
MibeniC is offline  
post #3 of 3 (permalink) Old 12-15-2008, 12:33 PM Thread Starter
BenzWorld Newbie
Date registered: Dec 2008
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
ahhh ok...its a 2001 model with 119K on the clock.
r11pak is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    NEW MEMBER WITH A E320 CDI ESTATE W210 kieron General Mercedes-Benz 0 10-14-2008 01:21 PM
    MERCEDES-BENZ E320 CDi Avantgarde HELP adam01 W210 E-Class 2 12-09-2007 04:40 PM
    CHARLIE´s S210, 2001 MB E320T CDI Avantgarde Charlie V12 W210 E-Class 16 05-30-2007 07:44 PM
    E320 CDI Avantgarde MH434 W211 E-Class 5 12-02-2006 09:19 PM
    e320 cdi Estate (Wagon) - Questions - USA? roane10 W211 E-Class 1 03-18-2006 11:58 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome