Problem w/keyless fob on c320 - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 12-08-2008, 02:32 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Dec 2008
Posts: 12
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Problem w/keyless fob on c320

Lately I have been having a problem with my keyless Fob for my C320, 2001. When it is cold like first start in the morning, i have to put it and take it out several times before it will activate the ignition and start. This has been going on for about 3 weeks now. I have replaced the batteries. Any solutions anyone???? Please help/
dalefkel is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 12-09-2011, 11:13 PM
BenzWorld Junior Member
 
Date registered: Nov 2010
Vehicle: 2001 C320
Location: Seattle
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Cold key issue, spread the word

Hi Guys...
I had an issue where my car would not unlock anytime it was cold in the evenings. Sometimes it would take a few clicks, but as it got colder, it could take a few hours and sometimes it just would not unlock, start, etc. after an exhaustive forum research with no results, I contacted my local Mercedes Benz dealer in Lynwood, WA and spoke with Garrett. He told me that it was most likely the EIS and they had seen this before. Sure enough that was it. It was not the battery, remotes, or anything of the sort. It was the EIS and I spent about $900.00 to get it replaced (it has to be coded, keyed, etc.). Everything is perfect now, but the expense was painful. However, not nearly as painful as waiting for my car to open in the morning. If your car has other issues other than not responding to the remote, it could be something else. BUt basically, if the remote wont open it or the ignition wont recognize the key, this is it! They are great cars which is why we drive them...but sometimes we have to bite the bullet. Good luck...B
c320goat is offline  
post #3 of 4 (permalink) Old 12-10-2011, 03:00 AM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,163
Mentioned: 3 Post(s)
Quoted: 289 Post(s)
Quote:
Originally Posted by dalefkel View Post
Lately I have been having a problem with my keyless Fob for my C320, 2001. When it is cold like first start in the morning, i have to put it and take it out several times before it will activate the ignition and start. This has been going on for about 3 weeks now. I have replaced the batteries. Any solutions anyone???? Please help/
Welcome to Benzworld. Please complete your profile as this will help members give you the most accurate answer to your questions. Location is also important when we need to help you find parts etc. This forum is for introductions only and all questions should be posted on the appropriate sub forum for your car.

To edit your profile simply click on quick links “edit profile” (quick links is top Right of the page)

At the bottom of the page you will find forum jump, click on this and view all the available sub forums and there you will find the technical forum for your car.

For FAQ see Benzworld help here:

Benzworld.org - Mercedes-Benz Discussion Forum - FAQ: General Forum Usage

Benzworld help is for general enquires and all technical questions should be posted on the specific forum for your car. If you are not sure which forum it should be on then please ask me and I will give you a link.

Regards

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is offline  
post #4 of 4 (permalink) Old 12-10-2011, 03:01 AM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,163
Mentioned: 3 Post(s)
Quoted: 289 Post(s)
Quote:
Originally Posted by c320goat View Post
Hi Guys...
I had an issue where my car would not unlock anytime it was cold in the evenings. Sometimes it would take a few clicks, but as it got colder, it could take a few hours and sometimes it just would not unlock, start, etc. after an exhaustive forum research with no results, I contacted my local Mercedes Benz dealer in Lynwood, WA and spoke with Garrett. He told me that it was most likely the EIS and they had seen this before. Sure enough that was it. It was not the battery, remotes, or anything of the sort. It was the EIS and I spent about $900.00 to get it replaced (it has to be coded, keyed, etc.). Everything is perfect now, but the expense was painful. However, not nearly as painful as waiting for my car to open in the morning. If your car has other issues other than not responding to the remote, it could be something else. BUt basically, if the remote wont open it or the ignition wont recognize the key, this is it! They are great cars which is why we drive them...but sometimes we have to bite the bullet. Good luck...B
Please start a new thread for your question on the following link;

W203 C-Class - Benzworld.org - Mercedes-Benz Discussion Forum

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Remote Keyless Entry Fob Programming Spotco2 W202 C-Class 10 11-18-2013 04:43 AM
    key fob problem markotono General Mercedes-Benz 4 05-24-2009 10:08 AM
    Replacement Keyless-Go Fob Key nyceric03 W211 E-Class 0 05-19-2007 07:38 PM
    keyless FOB Carlo$ R129 SL-Class 1 11-05-2006 09:24 AM
    97 C230 Remote Keyless Entry Fob Programming Spotco2 General Mercedes-Benz 1 04-21-2004 04:05 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome