Engine problems...need help - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 12-06-2008, 12:20 AM Thread Starter
BenzWorld Newbie
Date registered: May 2008
Vehicle: mb c200k
Location: constanta, romania
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Engine problems...need help

Hello everybody. I am quite new on this forum and, so far, I found very useful informations here. For that many thanks to everyone.
I have a problem now with my Mercedes c200 kompressor form 2001, automatic transmission.
3 months ago I had installed a LPG kit on my car. Since then the engine is not working properly. It sounds like a diesel engine and the alarm is on.
I went to the shop to see the error and it says misfire on cylinder 1. I changed the spark plugs (BERU), cleaned the injectors, changed the oil, oil filter, air filter, but no improvement.
To be known that this noisy behavior is only as long as the error is on (and the error appears only when engine is running on lpg), once I erased the error the engine is running well but with 1 liter more for 100km.

I talked to a mechanic from Mercedes and he said that if i could do something to trick the lambda sensor, which detects a lower O2 value, when running on lpg.

So, please, did anybody have any advice? Is quite frustrating to see that i paid 1000 euro for the lpg kit and I cannot use.

Thank you.
COPAEG is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    engine problems... Ryan27 R/C107 SL/SLC Class 14 07-05-2007 02:47 AM
    Engine Problems AxelWulff R170 SLK-Class 0 10-01-2006 06:21 PM
    Engine problems 89Benzo W124 E,CE,D,TD Class 7 07-29-2005 01:05 PM
    Strange Engine Sound - The Start of Engine Problems??? SLKDUDE R170 SLK-Class 3 04-28-2001 10:38 AM
    I think that my engine have some problems. Guest (MBNZ) W126 S,SE,SEC,SEL,SD,SDL Class 0 04-19-2001 12:10 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome