420 SEL fuel problem PLS HELP! - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 12-02-2008, 03:05 PM Thread Starter
BenzWorld Newbie
Date registered: Dec 2008
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Unhappy 420 SEL fuel problem PLS HELP!

Hi there looking for help with my Merc 420 SEL. The car had sat for around 6 months without being turned over, when I tried to start the car the engine turned over fine and all the plugs where sparking correctly but I noticed there was no fuel getting to the engine. Turned out the pumps where knackered, after having the pumps replaced the car ran like a dream, had been starting it bout twice a week with no problems until I went tried to start it the other day there. The car turned over as normal but just as it kicked to life it dies again, almost as if it not getting any fuel. I stripped down air filter housing to get access to the injectors, removed a screw in plug at the side of the injector ( As shown in photo) and fuel came out under pressure, when I turned the key to bring the ignition lights on, the pumps ran and fuel pours out the hole where I removed the plug. When I start the car with the with the plug out it runs fine, only problem is there is fuel pouring out of the hole, as soon as I tighten the plug again the engine just cuts off. Cant figure it out at all, thought it was maybe air but really not to sure. Any help appreciated thanks Gary McD

mcd240 is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Picture Fuel Pump Relay 420 SEL guarddog W126 S,SE,SEC,SEL,SD,SDL Class 3 09-01-2007 07:25 PM
    420 sel Hesitation Problem MrFJJ01 General Mercedes-Benz 3 03-14-2006 08:44 AM
    420 SEL Fuel pump / filters question Big D W126 S,SE,SEC,SEL,SD,SDL Class 2 05-12-2004 07:54 AM
    420 SEL Audio Problem Guest (MBNZ) Audio & Telematics Forum 0 01-03-2002 05:06 AM
    420 SEL fuel consumption. Guest (MBNZ) W126 S,SE,SEC,SEL,SD,SDL Class 4 11-25-2001 03:49 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome