s430 Drifting issues on Freeway - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 11-14-2008, 11:01 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Nov 2008
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
s430 Drifting issues on Freeway

My s430 is incredibly unstable on the freeway. Very sensitive to cross winds and grooves on the highway. I have had the car aligned 3 times, put new tires on it and no changes. All parts lok good underneath. I do have 2 different tires on the back than the front and from what I understand this could be the issue as well as using a cheaper tire could also be the problem. Please help.

Thanks
marketgy is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 11-14-2008, 01:21 PM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Lifetime Premium Member
The first thing I would do is try a set of 4 matched tires. Are the fronts and rears the same size but just different brands? "Cheap tires" or tires that are not the proper specs (load and speed rating) for your car are also possibilities.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
post #3 of 7 (permalink) Old 11-14-2008, 01:44 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Nov 2008
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Yes, right size but 2 different in the back than the front and yes they are cheap. Most of my cars have always been rear wheel drive cars so I never experienced issues like this, but the benz being independent suspension could pose its own set of problems if the proper tires are not on. I will match the back tires with the front and go through the process of elimination that way.

Thanks
marketgy is offline  
post #4 of 7 (permalink) Old 11-14-2008, 02:17 PM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Lifetime Premium Member
OK, good luck and I hope that solves the problem.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
post #5 of 7 (permalink) Old 11-14-2008, 04:03 PM
BenzWorld Junior Member
 
Date registered: Jul 2008
Posts: 29
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Turn the ESP on maybe?
Mercedes-Benz ///AMG is offline  
post #6 of 7 (permalink) Old 11-15-2008, 04:36 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Nov 2008
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Never thought of that, however the ESP defaults to on when I start the car, If I turn it off their yellow triangle lights up in the dash console. Is this correct?
marketgy is offline  
post #7 of 7 (permalink) Old 11-15-2008, 09:07 PM
BenzWorld Junior Member
 
Date registered: Jul 2008
Posts: 29
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by marketgy View Post
Never thought of that, however the ESP defaults to on when I start the car, If I turn it off their yellow triangle lights up in the dash console. Is this correct?
Yes. When you have the triangle on your dashboard, that means it's off. So I guess it automatically gets turned on. So sorry, I really don't know then. lol
Mercedes-Benz ///AMG is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    S430 2002 issues Airmatic dilsingh W220 S-Class 13 09-16-2013 03:35 AM
    s430 Airmatic issues jfendis430 W220 S-Class 25 12-19-2012 10:14 AM
    Electrical Issues With a 2002 S430 SD_Benz_Family General Mercedes-Benz 5 08-07-2008 11:03 PM
    s430 Remote Issues... Please Need HELP !! NEU-BUG W220 S-Class 7 01-15-2008 02:24 AM
    Drifting.... mrfu R170 SLK-Class 5 12-27-2004 02:20 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome