Problem with wipers?? - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 11-13-2008, 09:20 AM Thread Starter
BenzWorld Newbie
 
Date registered: Oct 2008
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Post Problem with wipers??

i have 97 C280

only problem i have is with wipers (well one wiper)...they do work but very slowly and usually does not return to its staring point. i dont know what problems is....so i wanted to see if anyone had same problem like this and how to fix it...



more detail: when i turn on wiper...it moves very slowly...( like its dragging itself) its take long time for it to clean my windshield...and then it just stops on its way back

anything would help!!!
lukabas is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 12-17-2008, 11:16 AM
BenzWorld Junior Member
 
Date registered: Aug 2008
Vehicle: 1994 C280
Location: Murfreesboro, TN
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Lukabas,
Just had wiper problem fixed on my 94 C280. Long story short, clean and regrease underneath the "cap" of the wiper. Good luck.
Lena Johnson is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Problem with Wipers - Please Help jsloan01 W203 C-Class 2 08-31-2005 09:39 AM
Wipers Bluefin 565 W163 M-Class 6 07-12-2005 02:29 AM
wipers MBeige W123 E,CE,D,CD,TD,TE Class 4 09-28-2004 01:02 PM
wipers bonnie22 BenzWorld Help 0 05-27-2004 06:13 PM
Wipers EeEe W211 E-Class 2 07-24-2003 09:39 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome