no reverse / jerks in reverse when cold - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 11-09-2008, 01:18 AM Thread Starter
BenzWorld Junior Member
Date registered: Nov 2008
Posts: 39
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
no reverse / jerks in reverse when cold

1994 Mercedes Benz S 320 SWB (140.032) L6-3.2L (104.994) (transmission—722.5) When I got this car it had no reverse and still doesn’t have. When the car is cold it jerks back but after it warms up it doesn’t even jerk. I was told that solenoid/actuator has to be changed but I want to hear your guys opinion. What I have done so far is took the oil pan off and valve assembly. After doing some research I found out that it is missing a Range Selector Valve. Is that a possibility?
Attached Thumbnails
Click image for larger version

Name:	92891312.jpg
Views:	97
Size:	57.0 KB
ID:	204047   Click image for larger version

Name:	2800809870102947174S600x600Q85.jpg
Views:	237
Size:	59.7 KB
ID:	204048  
datpet07 is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Reverse gone? DP W201 190-Class 2 08-24-2008 11:08 AM
    Reverse Von Vorschlag W140 S-Class 16 12-19-2007 10:30 AM
    OT:Reverse ?!! Binny W201 190-Class 16 01-21-2007 03:43 PM
    Reverse does not like cold canadian600 W140 S-Class 4 12-27-2006 08:38 PM
    Rumbling when cold or in reverse [?] murphys W123 E,CE,D,CD,TD,TE Class 4 03-28-2004 09:50 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome