'01 ML430 with the usual issues. - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 11-03-2008, 01:57 PM Thread Starter
BenzWorld Newbie
Date registered: Nov 2008
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Post '01 ML430 with the usual issues.

Just wanted to say that I love my ML but the repairs are killing me. I should be about through with the major stuff after the PS pump I guess. 82k miles on it and so far 1 full tune-up, MAF sensor, CPS, 3 coil packs, all plug wires, e-box fan, rear hatch struts, sunroof parts (the ones that break off). I have to keep the darn thing forever now or I'll lose too much trading it in. Anyway, don't get me wrong or send negative posts my way, I've always owned MB and VW and occasionally a Porsche and there's nothing like a German car. They all feel like an extension of the road. I'll be getting a G wagen next since I hear little in the way of issues with them. Who knows??
sladelittle is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    wide tires (275x55 R17's) on ML500 and ML430 issues? guy W163 M-Class 18 09-13-2011 02:17 PM
    Brake light issues on ML430. Can you pls help? Raserror W163 M-Class 1 07-27-2008 01:37 AM
    NEWBIE - please help!! ML430 Suspension issues, ESP/BAS light! helpsnic W163 M-Class 7 04-18-2008 12:52 PM
    Stumped (as usual) RBs W220 S-Class 5 04-18-2006 06:26 PM
    ML430 handling issues solved Benz4Dirt&Sky W163 M-Class 9 02-22-2005 09:58 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome