Help- Climate Control Issues - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 11-03-2008, 12:19 PM Thread Starter
BenzWorld Newbie
 
Date registered: Nov 2008
Vehicle: 1987 Mercedes 300D
Location: North Carolina
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Post Help- Climate Control Issues

I'm having climate control issues on my 1987 300D and need help. My air conditioning was running and all of the sudden the air became extremely hot so I tried to turn the system off but the off button would not work so I stopped and turned off the ignition. I few minutes later I turned the car back on and the air conditioning was cold as usual. About 5 minutes later the air turned extremely hot again and I had to turn off the ignition. I took it to my mechanic and the climate control unit was replaced as well as the mono value.

This is my problem: the air conditioning does not come on and in fact no matter where you set the temperature wheel its HOT, HOT HOT! When you turn it off the air flowing through the top vents is so hot you can literally burn your hand. If its not a defective mono value, what suggestions do you have for the problem? I don''t think it''s the air compressor (I hope) but I don''t know the components that might be involved.

I sure hope someone out there has seen this problem.
300dbenzer is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 08-13-2009, 09:48 PM
BenzWorld Newbie
 
Date registered: Sep 2006
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Did you ever find out what the problem was with this? Mine does the same thing.
tisdale36 is offline  
post #3 of 6 (permalink) Old 08-13-2009, 10:16 PM
BenzWorld Junior Member
 
slammer111's Avatar
 
Date registered: Dec 2004
Location: Vancouver, Canada
Posts: 26
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
How about a faulty or loose temperature sensor somewhere in the car? Maybe it always reads -20C or something. That would make the car try to crank up the heat.

2003 CL230K Orion Blue auto, panorama, rain sensor
slammer111 is offline  
post #4 of 6 (permalink) Old 08-14-2009, 12:27 AM
BenzWorld Newbie
 
Date registered: Sep 2006
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Where is temp sensor? I know it has to be in the cabin somewhere but where? It is unbelievably hot air coming out of vent. So hot I cant drive it. It would work nice in Antartica or something but not Texas.
tisdale36 is offline  
post #5 of 6 (permalink) Old 08-14-2009, 12:41 AM
BenzWorld Junior Member
 
Date registered: Jan 2007
Vehicle: Mercedes 200TE
Location: Cheshire, UK
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Usually behind some small unassuming grill, in my W124 and my W210 they are both near the interior light on the ceiling.
Just thinking though, the actual sensor may be behind the dash as in the W124 there is a pipe going from the grill down to the fan behind the dash so the sensor could be anywhere along that path. If you aren't confident taking things apart then I'd get a technician involved.

Last edited by Stu2000; 08-14-2009 at 12:45 AM.
Stu2000 is offline  
post #6 of 6 (permalink) Old 08-17-2009, 01:11 PM Thread Starter
BenzWorld Newbie
 
Date registered: Nov 2008
Vehicle: 1987 Mercedes 300D
Location: North Carolina
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Climate control issues

I did find out the problem....it has to do with vacuum lines.(Imagine that) I believe there are 4 lines in the climate control system and 2 of the lines had a problem. My mechanic cut those lines off and told me it may last a week or I may never have another problem. If it didn't work he said we would need to replace all of the lines including the bad ones since he would already be in there. To date I have had no further issues and the system is heating and cooling just fine. Iwas lucky in that he found the problem rather quickly. The line tracing could have taken a while but my mechanic is tops!!!!!
Hope this helps you out.
300dbenzer is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Climate Control Issues yoyomoefoe W140 S-Class 1 10-29-2008 11:19 AM
    Climate Control Issues kats24 C208/A208 CLK-Class 2 01-30-2007 10:05 AM
    Climate control issues????? Darkmann W163 M-Class 2 12-26-2006 05:13 PM
    Climate control Issues Tbilisi79 W140 S-Class 2 01-07-2006 03:47 PM
    climate control issues mark30H W201 190-Class 5 04-19-2005 09:07 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome