Thanks to MBForum for helping me resolve P0170 & P0173 problem on my ML320 - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 10-28-2008, 09:44 AM Thread Starter
BenzWorld Newbie
Date registered: Oct 2008
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Smile Thanks to MBForum for helping me resolve P0170 & P0173 problem on my ML320

Hi All,

I am new to this forum. I own a 1999 ML320. Broguht it new in Dec98. It only has 63K miles and had no major issues till six monts ago except breaks and sunroof problem. About 6 monts ago, the check engine light came on. During my service MB Dealer checked and said it would need a mass air meter and that it would cost me about $700. I denied the repair but the dealer any way charged me $150. I was mad that they charged me so much but paid and got out of dealership hoping to take care of it later. Since my inspection is due in December, I was trying to see how to get this fixed at a low cost. The information posted on this site has helped me order the parts ( Bosch Aire meter and Air filter ) from AutohausAZ and have been able to repalce both these myself for about $185 myself. My sincere thanks to all of you on the MB forum for your wonderful posts. With the help of some of the posts in the forum, I actually was able to convince MBUSA and have my CATS checked for free for any cracks. I used information from the link provided here which states that MBUSA had settled a claim with EPA and would voluntarily inspect \ repalce if required the CATS on 1999 - 2001 ML320 for most VIN's. The details of claim settlement are available in the link : Mercedes Clean Air Settlement | Civil Enforcement | Compliance and Enforcement | US EPA

My check engine light is gone ( I reset by disabling the battery ) and have run it over 200 miles. It has been over two weeks now. My ML now runs like new again.

Again, thanks a lot.. You guys are the best.

svindyala is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Error codes P0100 & P0110 + P0170 & P0173 MADSLEG W163 M-Class 5 11-07-2011 11:49 AM
    P0170 P0173 REVISITED bmmrbill W163 M-Class 11 10-28-2008 12:41 PM
    P0170 & P0173 codes ATYSLK320 R170 SLK-Class 9 07-05-2008 09:54 AM
    P0170 and P0173 codes blm W210 E-Class 7 05-12-2008 03:36 PM
    ERROR CODE P0170 & P0173 Shipsake W210 E-Class 9 10-17-2007 09:21 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome