blue smoke cdi - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 10-21-2008, 01:12 PM Thread Starter
BenzWorld Junior Member
 
plasterer's Avatar
 
Date registered: Oct 2008
Vehicle: vito 110cdi
Location: merseyside
Posts: 41
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
blue smoke cdi

110 vito with the cdi engine. I have a ploom of blue smoke on the cold start but this fades after driving off and is soon unoticable. the injection system has just been checked and all is well there. could it be the oil i put in recently is to thin as i have heard of weak viscosity oil leaking past seals on MB. ? anyone had this prob with commonrail before? ta
plasterer is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 10-21-2008, 10:38 PM
BenzWorld Elite
 
Diesel Benz's Avatar
 
Date registered: Dec 2005
Vehicle: 222.132 & 221.122 & 212.025 & 906.633
Location: Europe
Posts: 10,322
Mentioned: 3 Post(s)
Quoted: 34 Post(s)
Quote:
Originally Posted by plasterer View Post
110 vito with the cdi engine. I have a ploom of blue smoke on the cold start but this fades after driving off and is soon unoticable. the injection system has just been checked and all is well there. could it be the oil i put in recently is to thin as i have heard of weak viscosity oil leaking past seals on MB. ? anyone had this prob with commonrail before? ta
0W/xx oil is good for the MB, I don't think you can find lower viscosity oil that fulfils MB engine oil requirements.

Any idea about the age/mileage? Did you put the correct amount of oil too?

Is the engine otherwise OK?
Diesel Benz is offline  
post #3 of 3 (permalink) Old 10-22-2008, 04:19 PM Thread Starter
BenzWorld Junior Member
 
plasterer's Avatar
 
Date registered: Oct 2008
Vehicle: vito 110cdi
Location: merseyside
Posts: 41
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
The engine is good when warm 56k on the clock 52plate. I have just been told the injectors were sealed fine no leaks and all spraying but the guy has had them sent away for a full examination as he could not seem to narrow the problem down and the company have phoned him back saying all 4 are f####ed. Its a strange world the one of commonrail diesel injection. I still got a feeling oil is being burnt as the smoke looks blue in my opinion.
plasterer is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Blue Smoke jwratts W210 E-Class 5 07-24-2007 06:20 AM
    blue smoke annasdad W210 E-Class 1 11-12-2006 06:34 AM
    Blue smoke modulacom W126 S,SE,SEC,SEL,SD,SDL Class 18 02-12-2005 03:57 AM
    blue smoke Kiwi_bloke W124 E,CE,D,TD Class 2 09-21-2003 02:31 PM
    More on Blue Smoke timberock W126 S,SE,SEC,SEL,SD,SDL Class 2 10-08-2002 05:49 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome