Hello. - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 10-17-2008, 08:52 PM Thread Starter
BenzWorld Newbie
Date registered: Oct 2008
Vehicle: 2002 G500, 2006 BMW 750Li
Location: Houston/Spring, TX
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)

Hello, I am about to purchase my first MB. I will be picking up my 2002 G500 tomorrow. I hope to stay and learn somethings here. I currently have a 2006 BMW 750Li, and a 1996 Range Rover 4.0SE.
houstonsnk is offline  
Sponsored Links
post #2 of 2 (permalink) Old 10-17-2008, 09:12 PM
BenzWorld Elite
Date registered: Oct 2007
Vehicle: 2002 SLK 230 1986 560SL 2008 Honda CRV
Location: Rochester,NH USA
Posts: 3,664
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Welcome aboard, fill in your profile when you get the time this will help others answer your questions.
livefreeordie is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome