99 ml430 won't start - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 10-13-2008, 06:56 AM Thread Starter
BenzWorld Newbie
Date registered: Oct 2008
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
99 ml430 won't start

I have a problem I wanted to see if anyone could help me. I have a 99 ML430 it won't start. Last weekend I could not get the key to turn and it would not unlock the steering. I got it to turn and I had my wife to leave the key in the ingiton and not to remove it until we have it fixed. Mecedes wanted 130 for key switch and 570 to install it. She drove it all week no problem until friday she was going down the road and it died. It would not start won't turn the engine over no clicking or nothing. Battery good 12.7v, headlights strong, Radio works, power seats work - dome lights dead, power windows dead, door locks dead. Power outlet won't work either. Does anyone know what could be wrong. Please Help
rgriffin17 is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    ML430 didn't start hchambi W163 M-Class 2 08-13-2007 10:54 PM
    2000 ML430 Cranks but won't start Detari_SR W163 M-Class 0 09-14-2006 06:13 AM
    99 ml430 wouldn't start.... then it did? mikewired W163 M-Class 9 06-12-2006 04:58 AM
    '99 ml430 won't start fredgar W163 M-Class 7 12-14-2004 07:43 AM
    ML430 Wont start ALo W163 M-Class 5 08-10-2004 08:51 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome