New Member - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 10-08-2008, 08:05 PM Thread Starter
BenzWorld Newbie
Date registered: Sep 2008
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
New Member

Hi all !
I have just purchased my first Benz.
2003 C 230, Kompresor, std trans, leather, 6 cd changer, pano roof.
But alas I have a problem I can't figure out.
yes I have searched the site and found some good guidance.
the CEL came on and I got a P0128, eng temp too low, freeze frame data indicates 165 F. I have changed the thermostat (benz part) and the temp sensor (Benz part) and it is still running cold (still setting off the CEL) I live in Canada and the dash guage reads 71 - 80 Celcius which converts to 160 F to 175 F
leaving the car in driveway and running it for 10 minutes the water circulates and fan cuts in when the A/F reaches 192 f measured from the overflow tank and the dash gauge reads 92 C = 197 F
so do I have a bad thermostat ? the old and new one keep the same temp..
thanks for any help People !!!


2003 C 230 Kompressor
johnc230 is offline  
Sponsored Links
post #2 of 6 (permalink) Old 10-09-2008, 10:51 PM
BenzWorld Member
Date registered: Jun 2004
Vehicle: 2008 c350, 2004 c240
Location: Mission Viejo, Ca
Posts: 305
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Are you using the proper coolant? MB has their own formula.
wblynch is offline  
post #3 of 6 (permalink) Old 10-09-2008, 11:14 PM
BenzWorld Elite
Date registered: Oct 2007
Vehicle: 2002 SLK 230 1986 560SL 2008 Honda CRV
Location: Rochester,NH USA
Posts: 3,664
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
I don’t think the formula makes a difference, the sensor is reading the temp. not the chemical makeup of the coolant. Sounds like the sensor may be bad or a loose wire when it was replaced.
livefreeordie is offline  
post #4 of 6 (permalink) Old 10-10-2008, 10:46 AM Thread Starter
BenzWorld Newbie
Date registered: Sep 2008
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
I haven't added any coolant, it is fairly clear in color so I'm assuming MB stuff.
I did double check the wiring for the sensor and the gauge moves so the wiring works.
someone mentioned that it could be a summer thermostat, there is only one listing for the make and model of car.
Thanks for input !

2003 C 230 Kompressor
johnc230 is offline  
post #5 of 6 (permalink) Old 10-11-2008, 04:15 AM
BenzWorld Newbie
Date registered: Jun 2008
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
New Member

Hi I am Edward I was very much interested by reading this forum. Here we are finding many answers for our questions. Without asking also we are solving our problems. Thanks for this best forum.
Edward Eaton
eeaton2020 is offline  
post #6 of 6 (permalink) Old 12-05-2008, 12:46 PM
BenzWorld Junior Member
Date registered: May 2007
Posts: 9
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
same problem

p0128 . Clear the code but again came back after 2 weeks.Dealer just want 250 for diagnostic .Do not know just replace thermostat and cross my fingers that it works or ther might be another problem ,coolant fluid changed by dealer 1 year ago and the level is fine .Any idea appriciate so much.
mfotovati is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Another new member TahoeML500 General Mercedes-Benz 0 07-21-2008 04:08 PM
    new member skortboy General Mercedes-Benz 0 07-21-2008 10:06 AM
    Hello everyone, new member here... ikarma R170 SLK-Class 6 04-11-2006 06:42 PM
    New Member!!! BenzE500 W211 E-Class 2 12-22-2005 11:33 PM
    wtf, i'm a "member" here but i'm a "senior member" at MBWorld!! asianml Off-Topic 8 11-23-2005 05:19 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome