Strange problem in starting - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 10-06-2008, 03:47 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Apr 2008
Vehicle: 2007 W221 S350
Location: UAE
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Strange problem in starting

I drove back from office today on my E240 2004 and everything was fine. After an hour, i cranked the engine, it started for a few second and then stalled. Felt like no fuel was being delivered!! after that i tried many times but it never started.

a few hours later, i cranked again and it started that time. everything is fine now.

why was that problem?? anything serious to worry about???
shams13 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 10-06-2008, 06:51 PM
BenzWorld Elite
 
Check Codes's Avatar
 
Date registered: Mar 2005
Vehicle: '01-E320 & 02-ST2
Location: John 15:18-19
Posts: 31,634
Mentioned: 0 Post(s)
Quoted: 35 Post(s)
Quote:
Originally Posted by shams13 View Post
I drove back from office today on my E240 2004 and everything was fine. After an hour, i cranked the engine, it started for a few second and then stalled. Felt like no fuel was being delivered!! after that i tried many times but it never started.

a few hours later, i cranked again and it started that time. everything is fine now.

why was that problem?? anything serious to worry about???
Hi, Shams, and welcome to the forum. Please take a minute to click the user cp link and complete your BW profile re: vehicle and location as that is very useful information -- especially when you're asking for help.

You have a W211 and there is a forum specific to that chassis, scroll down into the sedans section and you'll see it. This general forum may or may not yield useful information for you.

That said, your symptoms sound to me very much like a failing crank position sensor; it's a fairly common problem. I would guess it is in a similar location to the V-engine in the W210 and there are pictures and DIYs for it in that forum. But were I you I'd search in the 211 forum for CPS and see what you find, if not much then post in there for inquiries.

Take care and enjoy the ride,
Greg

Socialism is a philosophy of failure, the creed of ignorance, and the gospel of envy; its inherent virtue is the equal sharing of misery. (Winston Churchill)
Check Codes is offline  
post #3 of 3 (permalink) Old 10-07-2008, 01:16 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Apr 2008
Vehicle: 2007 W221 S350
Location: UAE
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
thank you greg. i will update my profile.
and i will dig into the CPS problem as well.
shams13 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Strange Behavior When Starting pchan7 W204 C-Class 2 08-08-2008 11:16 PM
    Strange starting issue NZ Benz W140 S-Class 27 05-30-2008 01:27 AM
    Strange problem when starting... BrisK230 R170 SLK-Class 3 10-08-2006 05:24 AM
    Starting Problem (Back window rolls down when starting up the car) fastneutron W202 C36 AMG, C43 AMG 3 08-08-2004 11:23 AM
    strange starting problem mercbuff W126 S,SE,SEC,SEL,SD,SDL Class 12 02-27-2003 09:20 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome