Turn signal, high beam, wiper shaft loose - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 09-25-2008, 12:20 PM Thread Starter
BenzWorld Newbie
 
Date registered: Sep 2008
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Turn signal, high beam, wiper shaft loose

I have a 1997 E300. The turn signal lever has gotten loose. I can't tell if something broke inside or it popped out of a socket. It pulls out slightly and the high beams are activated when the lever is pulled up or down for turn signaling. Does anyone have a diagram of how the shaft connects inside?

It is pretty difficult to see how it connects. Does anyone have experience correcting this problem. I would sure like to avoid pulling the whole wheel off if possible.

I have no problem with the cruise control shaft so the collar on the steering column is fine. The problem is where the turn signal lever attaches inside the column.

Thanks for your help.
sbbrian is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 09-25-2008, 01:18 PM
BenzWorld Elite
 
flyboyike's Avatar
 
Date registered: May 2003
Vehicle: 2012 Focus SE
Location: Ormond Beach, FL
Posts: 7,704
Mentioned: 1 Post(s)
Quoted: 70 Post(s)
My guess is that you broke the switch in a particularly aggressive blinker activation.

Felicita e un bicchiere di vino con un panino.
flyboyike is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
97 E320 Combination switch (turn signal,wiper,high beam) alfa01 W210 E-Class 3 05-10-2013 06:56 AM
W210 - loose turn signal fix durado W210 E-Class 20 11-19-2012 08:55 AM
High Beam Flash and Right Turn Signal Problems dsepuha W210 E-Class 2 03-24-2011 11:02 PM
Turn signal wiring harness is loose - any solution? bob98e320 W210 E-Class 0 05-22-2006 04:18 PM
Help! Need Turn Indicator/Horn/Wiper/Hi-Beam Switch bbrah G-Class 16 07-21-2005 07:10 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome