Vaccuum Problems, High Idle. Please Help! - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 09-12-2008, 08:35 PM Thread Starter
BenzWorld Junior Member
Date registered: Sep 2008
Posts: 11
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Vaccuum Problems, High Idle. Please Help!

Hello all, and thank you in advance for helping a mercedes newbie.

I am having some obvious issues with the vaccuum system on my newly acquired 1975 450SL Roadster. I bought it last month and it really has a high idle. I thought it was because it hadn't been run in a while and there were some fuel/intake problems. Come to find out, someone had cut a bunch of the vaccuum lines. There has to be someone out there that has a working knowledge of which lines go to what and what the "what" looks like. I have checked both manuals on the subject, yet I don't have a real clue as to what they are talking about. I am a visual person and will need someone to actually tell me exactly what lines go what and where that "what" is located. If there is such a person or a forum thread I haven't found to date that clearly spells this out for my specific model, then by all means, please point me to that person. I have done a ton of maintenance on the car already and would like to get this small problem out of my hair. I am trying to upload some pics of my system, but I think this website won't accept due to a small server or something.

Travis Hobbs
travishobbs16 is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Testing Idle Valve - High Idle Problem Jonathan Laws W126 S,SE,SEC,SEL,SD,SDL Class 16 08-11-2012 05:55 AM
    HELP! High & Erratic Idle - Won't idle down soltek W201 190-Class 83 12-22-2011 08:07 PM
    High neutral idle + once in gear way rough idle Rickysa R/C107 SL/SLC Class 3 04-12-2008 12:50 PM
    Help! Normal idle when Cold/ High idle when Hot VicsBenz W201 190-Class 20 03-23-2007 08:58 PM
    Rough idle Vs high idle NewMBie W126 S,SE,SEC,SEL,SD,SDL Class 3 12-29-2004 09:17 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome