Intermittent A/C problems with my 1998 C230 - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 08-30-2008, 10:49 AM Thread Starter
BenzWorld Newbie
Date registered: Aug 2008
Vehicle: 1998 C230
Location: San Antonio, Texas
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Question Intermittent A/C problems with my 1998 C230

Fault: Air conditioner runs for approximately 3 minuets then the compressor shuts down. I ran the N22 diagnostics and error codes 419 and 416 appeared. I personally replaced the A/C clutch and the recirculation pump. This appeared to have corrected the problem. However, three weeks later I’m faced with the same issue. I ran the same diagnostics and no error codes were reported. I replaced the battery since it was the original battery. I, also, replaced the radiator cap for the same reason. I’m not sure if the N22 climate control computer is brain dead or the electrical connections to the unit have corrosion, therefore giving me intermittent faults. I tried running the heater to burn off any condensation that may have accumulated on the evaporator sensor to see if that could be causing my problem. At first it seamed to work, but after several days I was back to the same problem. I repeated the heater routine with no luck and the N22 still reports no errors. Using the N22, I tried reading the actual values from all acquisition devices and several values don’t correlate to the diagnostic tables in the manual. Below are actual values:

01 In care temperature sensor -- 92 degrees symbol F
02 Outside temperature indicator-- 87 degrees symbol F
03 Heater Core temperature sensor-- 86 degrees symbol F
04 Not used
05 Evaporator temperature sensor-- only the number 144 appears
06 ECT sensor: only the number 138 appears
07 Refrigerant pressure: 07 degree symbol 4 or 7.4 bar
08 Refrigerant temperature sensor; 95 degree symbol 4 or 95 deg F
09 Not used, however 35 degree symbol F appears
10 Blower control voltage: only the number 400 appears
20 Control current for auxiliary: 35 degree symbol 0 appears
21 Engine speed: 070
22 Vehicle speed: 000
23 Battery voltage: 000
24 Value 24 Not listed in diagnostic table, but gives value of 13.6
40 Software status: 02
41 Software status: 3
42 Version code 1: 18
43 Version code2: 6-c
50 Not used: value shown is 84 degree symbol F
51 Not used: value shown is 72 degree symbol F
52 Not used: value shown is 50 degree symbol F
54 On –Off A/C compressor: OFF

Can anyone tell me if my version code is correct, because some of the values shown don’t agree with the diagnostic table?
radavi4 is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    2006 C230 with intermittent radio failure on startup, am I the ONLY ONE !!! rhody527 Audio & Telematics Forum 6 01-20-2012 11:48 PM
    1998 c230 with cup holder problems dennis_larson W202 C-Class 15 07-16-2009 05:46 PM
    2000 c230 a/c intermittent HELP!!! wolfshaus W202 C-Class 0 08-12-2008 06:01 PM
    1998 C230 two unrelated problems Izzum88 W202 C-Class 1 12-16-2004 07:38 AM
    Intermittent Nav Problems ccweems W163 M-Class 3 08-16-2003 10:33 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome