2001 E320 Audio failure - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 08-26-2008, 09:09 PM Thread Starter
BenzWorld Newbie
 
Date registered: Aug 2008
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
2001 E320 Audio failure

Hi,
I recently bought a 2001 E320 used in pretty good shape.
I noticed that the CD players wasn't working though... specifically
I could put CD's in, but the radio console would keep saying CD not
connected. Then a few weeks later the radio stopped working all together
with the SERVICE logo on it. I noticed the same thing for the TELE

What could be causing this ? Could it be a fuse issue ? is so where is the fuse
and also would changing the fuse result in me having to enter a password ?


best
novicejoe is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    2001 C240 Brake light failure leading to ESP/BAS Failure lxshk Audio & Telematics Forum 1 08-04-2008 10:54 PM
    2001 sl500 oxygen sensor failure Baby500 R129 SL-Class 18 07-12-2008 07:27 PM
    EIS failure??? - 02 E320 craighess Audio & Telematics Forum 1 02-25-2008 11:51 AM
    questions regarding xm & audio in 2001 E320 fju2112 W210 E-Class 5 05-16-2006 10:44 AM
    2001 ML320 - Remote failure - Need Help Hernando W163 M-Class 2 07-18-2005 12:42 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome