95 s320 electrical problems - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 08-09-2008, 02:37 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Aug 2008
Posts: 10
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
95 s320 electrical problems

I just bout a 1995 s320. The car runs great. The problem is the car blows the fuse for the power seats/wheel and a few other things in like 15 seconds. The climate control doesn't show anything on the lcd's and no hot or cold air will blow. What could be causing this because I'm from Cincinnati and the heat is going to be a major issue?
320sAndrew is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 08-09-2008, 08:04 PM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Lifetime Premium Member
I realize you are new but you have a W140, so try posting this on that specific forum. From what I've read, you'd better pray it's not your evaporator!

Seriously though, the A/C doesn't sound like your evaporator to me, and more likely the blower motor. LCDs could be a bulb...

Mercedes Benz - Das beste oder nichts!

Last edited by Musikmann; 08-09-2008 at 08:07 PM. Reason: change
Musikmann is offline  
post #3 of 3 (permalink) Old 08-11-2008, 05:56 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Aug 2008
Posts: 10
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
d

Sorry I didn't know what a w140 is I've only had Audi's.
320sAndrew is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
S320 Transmission problems!!!!!!! Dopeboymajik W220 S-Class 5 09-15-2013 05:39 AM
94 s320 a/c problems mr horsepower W140 S-Class 6 07-21-2008 04:26 PM
electrical problems, please help renelsisc W140 S-Class 3 05-03-2008 10:23 PM
S320 V6, engine problems, need help Oddemann W220 S-Class 1 11-20-2007 10:24 AM
S320 - Suspension Problems wilko_76 W220 S-Class 1 05-28-2005 05:30 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome