Limp mode? - Page 6 - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #51 of 54 (permalink) Old 08-18-2008, 04:50 PM
BenzWorld Elite
Jayhawk's Avatar
Date registered: Aug 2005
Vehicle: S500/W220/2000
Location: Lawrence, KS (USA)
Posts: 21,652
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
Originally Posted by Kajtek1 View Post
It is nice it is "free" but wouldn't you expect more from MB technician driving the truck?
Those guys don't even carry OBDII scanners, so their help is on the level of gas station attendant.
MB battery with free installation has 2-years warranty for about $200.
Costco sells good battery with 100 months warranty for about $80
My experience has been completely different than yours.

Don't believe everything you think
Jayhawk is offline  
Sponsored Links
post #52 of 54 (permalink) Old 08-18-2008, 08:47 PM
BenzWorld Elite
Kajtek1's Avatar
Date registered: Dec 2005
Vehicle: W211 E320 Bluetec R129 SL500 - $1300 car ........ Ford F350 6l
Location: CA Bay Area
Posts: 31,520
Mentioned: 9 Post(s)
Quoted: 1059 Post(s)
Originally Posted by Jayhawk View Post
My experience has been completely different than yours.
Like what? You had MB roadside assistance coming to you with Star computer?
Or selling you battery for $60?
Kajtek1 is online now  
post #53 of 54 (permalink) Old 09-04-2008, 05:23 PM
BenzWorld Junior Member
w2115's Avatar
Date registered: Sep 2008
Vehicle: 2004 E500
Location: new jersey
Posts: 13
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
somtimes the transmision connector plugs leek,, look for signs of trans oil on the floor, that dose make the car go on limp mode" but if there isent any just reset the codes and drive see if it is still the same. keep me posted.
w2115 is offline  
post #54 of 54 (permalink) Old 09-04-2008, 11:10 PM
full house's Avatar
Date registered: May 2007
Posts: 199
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
I think there are some links in the engine or transmission.Have you tried to check it? Maybe while driving the fuels are licking out of the road that's why you are getting slow.
full house is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Limp Mode noelchambers R170 SLK-Class 4 08-18-2008 01:27 PM
    LIMP MODE V-TECH W203 C-Class 0 06-27-2008 12:43 PM
    LIMP MODE djblu R129 SL-Class 12 08-14-2007 05:21 PM
    limp mode??? Dolphin27 R170 SLK-Class 1 01-04-2006 03:02 PM
    What is "limp mode"? xraider W202 C-Class 1 02-23-2004 05:20 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome