1988 300CE STALLED IN TRAFFIC AND WON'T START - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 07-30-2008, 06:18 PM Thread Starter
BenzWorld Member
 
Date registered: Jul 2008
Vehicle: 1988 300CE
Location: Ottawa/Gatineau, Canada
Posts: 62
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
1988 300CE STALLED IN TRAFFIC AND WON'T START

Hi there. I'm new to the site, if anyone can help me, that would be great....

A few days ago I started my car (it was already warm) and it stalled right after it started. I started it again and no problems.
The following day I started it and it idled rough like it wanted to stall. Once it got warm and drivin it appeared to be running fine. I got into some downtown traffic and it stalled and hasn't started since (I got it towed home).
It turns over strong but won't start. I am guessing that maybe it is either the crank sensor, fuel pump, fuel pump relay or fuel filter....but I'm only guessing, I don't have any experience with this model (it has the 3.0L inline-6). I have only owned a 87 190E 2.6 and a 99 ML430.
If anyone has any advice, it would be greatly appreciated!!!
It has 240,000kms (dealer maintained)
Benzy B is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 07-31-2008, 07:25 AM
BenzWorld Elite
 
flyboyike's Avatar
 
Date registered: May 2003
Vehicle: 2012 Focus SE
Location: Ormond Beach, FL
Posts: 7,699
Mentioned: 1 Post(s)
Quoted: 68 Post(s)
If you have experience with the 2.6, you current steed isn't all that different. Can you hear the fuel pump at all?

Felicita e un bicchiere di vino con un panino.
flyboyike is offline  
post #3 of 6 (permalink) Old 07-31-2008, 08:10 PM Thread Starter
BenzWorld Member
 
Date registered: Jul 2008
Vehicle: 1988 300CE
Location: Ottawa/Gatineau, Canada
Posts: 62
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thank You for your response!

Yes, I hear the fuel pump(s). Does that mean that the fuel pump(s) are ok?There is two of them. If one of them is done, will I still not be able to start it?
Do you know a good way to test the fuel pump(s)? I heard I could spray carb cleaner in the air intake tube while the engine is being turned over and if it ignites, it is the fuel pump(s).
Thanks for your time!
Benzy B is offline  
post #4 of 6 (permalink) Old 08-02-2008, 11:40 PM Thread Starter
BenzWorld Member
 
Date registered: Jul 2008
Vehicle: 1988 300CE
Location: Ottawa/Gatineau, Canada
Posts: 62
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Any suggestions out there?

If anyone has any suggestions, please reply. thanks!
Benzy B is offline  
post #5 of 6 (permalink) Old 08-03-2008, 09:12 AM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Lifetime Premium Member
Try replacing the crankshaft position sensor.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
post #6 of 6 (permalink) Old 08-03-2008, 11:23 AM Thread Starter
BenzWorld Member
 
Date registered: Jul 2008
Vehicle: 1988 300CE
Location: Ottawa/Gatineau, Canada
Posts: 62
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Would it show a code?

If it is the crankshaft position sensor, would it show a code?
I had the CPS go on my 99 ML430 before I sold it, it had 225,000kms on it, so you may be right! What about rough idling the morning it stalled, would the CPS cause that too?
Thanks for your reply.
Benzy B is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    95 S420 stalled, won't start anymore! johnson154 W140 S-Class 6 12-21-2011 03:49 AM
    1988 300CE STALLED IN TRAFFIC AND WON'T START Benzy B General Mercedes-Benz 0 07-30-2008 06:14 PM
    1988 300CE ehpotsirhc W124 E,CE,D,TD Class 2 07-03-2008 11:31 AM
    engine stalled and won't start right away pete168 W201 190-Class 2 11-21-2002 07:53 PM
    300CE running warm in traffic...100-110degree Hai Hoang Phan W124 E,CE,D,TD Class 5 09-10-2002 10:21 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome