Did my engine blow up / engine gone? - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 07-26-2008, 11:59 PM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2008
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Did my engine blow up / engine gone?

Driving on the interstate tonight at 75mph I look down at my temp gauge on the dash and it's off the charts into the red. I have a digital water temp gauge also that I put on and it shows normal (about 190 F). So I think the gauge is wrong as I've had electrical issues with the instrument cluster.

Well after 5 minutes or so the engine just stops dead. I pull over and open the hood and I'm blased with white smoke and the stench of what I can describe as a burning plastic smell. Had the car towed home. Oil level full. Water resevoir full. When I try to start the engine it doesn't sputter or jump or turn over or crank. Just sounds like "veeeveeeveeeveeeveee" until the started drains the battery.

Did I blow the engine? It looks physically fine from the outside.

1991 350 SD
158k miles
johnhere is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 07-27-2008, 08:54 AM
BenzWorld Elite
 
Date registered: Feb 2008
Vehicle: 2004 W220 (S430) ; 2001 R129 (SL500) Sport
Location: Alabama Gulf Coast--formerly Charlottesville, VA
Posts: 1,335
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
I can't say whether your car has cooked the motor, but I had a similar experience in a SAAB 9000. The symptoms were exactly the same as you describe; no piston hanging out the side of the block, no puddle of oil or coolant--just dead. The oil pump had packed up and the engine was seized. No repair possible--replace the motor or junk the car. I hope that's not what happened to you.

"Don't pick a fight with an old man. If he is too old to fight, he'll just kill you."--John Steinbeck
DrJfrmLA is offline  
post #3 of 3 (permalink) Old 07-27-2008, 11:46 AM
BenzWorld Elite
 
Jayhawk's Avatar
 
Date registered: Aug 2005
Vehicle: S500/W220/2000
Location: Lawrence, KS (USA)
Posts: 21,652
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Wow! Can't imagine what happened, but please let us know when you find out...

Don't believe everything you think
Jayhawk is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Engine Blow on 10 day old SLK200 beverage R171 SLK-Class 4 02-01-2006 09:22 AM
    what are the signs to watch if your engine will blow by? red_dragon W124 E,CE,D,TD Class 5 08-08-2004 04:28 AM
    engine blow-by zoran W123 E,CE,D,CD,TD,TE Class 3 08-07-2004 12:59 PM
    is there anywhere on a 230 engine where i could custom fit a blow-off valve? SilverSport R170 SLK-Class 16 02-01-2002 02:21 AM
    WHAT CAUSES ENGINE BLOW -BY? Guest (MBNZ) W123 E,CE,D,CD,TD,TE Class 3 03-31-2001 06:49 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome