1999 E320 Wagon 4Matic Stalling - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 07-21-2008, 08:49 AM Thread Starter
BenzWorld Member
 
Date registered: Jul 2008
Vehicle: 1999 E320 4matic Wagon
Location: New York, NY
Posts: 61
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
1999 E320 Wagon 4Matic Stalling

New to this forum and am hoping someone has been through this already. I've searched most of the posts and haven't found the same exact problem.

We have a 1999 E320 Wagon 4Matic and has been running beautifully for years. However, recently the car stalled while driving and would not start again. We waited a few minutes and the car started up. That was about a month ago and the car had been fine up until now. Now, every day, the car will run for about 10 blocks or 20 minutes and stall out, same deal.. wait and it starts up again. The problem is getting worse, and the length of time to wait is now about 30 minutes. Others on this forum have posted similar stalls, but we have had no check engine light. We've done the oil change, checked the fluids, etc.. all fine. We bought the fuel filter to replace, but haven't found where it is on the driver's side.

Recently, we changed the sparks and just now, the battery. I assume that it is temperature related and some sensor is going off preventing further driving. I don't think it's a fuel problem, we only use 93 and there is no hesitation. Side notes, the A/C runs frigid, radio/CD, headlights, all stay on after the engine stall.

I'd rather not have a parts roulette and hope for the best. Does anyone know what's up, or what the next part I should replace? I was looking for an OVP and Crank Position Sensor that another post suggested, but again, we never and still don't have a check engine light.

The last random thing is that I cannot reproduce the stall in my driveway. In our last 95degree heatwave, I let it run with the a/c blasting for 25 minutes and no stall. Maybe I have just not waited long enough, or it is something else.

Thanks in advance for any of your help! I'd like to DIY versus taking it to the dealer.
sleepysan is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 07-21-2008, 10:34 AM
BenzWorld Veteran
 
E-Class Owner's Avatar
 
Date registered: May 2007
Vehicle: 2003 Mercedes Benz E500
Location: San Francisco Bay Area
Posts: 654
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
a CPS typically will not trigger

a check engine light... Your symptoms sound like classic CPS failure... Inexpensive [relatively] part and relatively easy DIY. Check the W210 forum "stickies" for the details.

Good luck,

JR
E-Class Owner is offline  
post #3 of 9 (permalink) Old 07-21-2008, 11:37 AM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Lifetime Premium Member
+1 with E-Class Owner.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
post #4 of 9 (permalink) Old 07-21-2008, 11:46 AM Thread Starter
BenzWorld Member
 
Date registered: Jul 2008
Vehicle: 1999 E320 4matic Wagon
Location: New York, NY
Posts: 61
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks E-Class Owner I thought about changing the CPS sensor anyways, but I can't find it. Would anyone know where it would be? I've seen a couple of pictures of the part and also the general placement.. but I can't find it or don't know that I am looking at it. Do you think that the "1996 - 2003 Mercedes-Benz 210 Chassis Family Factory Service Manual on DVD-ROM" is worth the 200 bucks to help me diagnose the problem?

Last edited by sleepysan; 07-21-2008 at 11:52 AM.
sleepysan is offline  
post #5 of 9 (permalink) Old 07-21-2008, 12:10 PM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Lifetime Premium Member
Check at the top of this forum and there is a sticky explaining how to replace it.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
post #6 of 9 (permalink) Old 07-21-2008, 01:46 PM Thread Starter
BenzWorld Member
 
Date registered: Jul 2008
Vehicle: 1999 E320 4matic Wagon
Location: New York, NY
Posts: 61
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
I did a parts search Musikmann, would you know if it is a Single or Double on my engine?
sleepysan is offline  
post #7 of 9 (permalink) Old 07-21-2008, 01:58 PM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Lifetime Premium Member
Sorry, no, I do not. The parts supplier you choose should be able to match your VIN to the correct one. A lot of people recommend: Auto Parts at AutohausAZ - OEM Auto Parts - Discount Replacement Parts, Resources and Car Care Tips

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
post #8 of 9 (permalink) Old 07-25-2008, 01:32 PM Thread Starter
BenzWorld Member
 
Date registered: Jul 2008
Vehicle: 1999 E320 4matic Wagon
Location: New York, NY
Posts: 61
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Worked like a charm. Thanks for the Autohaus, they were fast.

I also heard that the next sensor to go is the Airflow sensor. Any ideas on how to change that?
sleepysan is offline  
post #9 of 9 (permalink) Old 07-26-2008, 10:16 AM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Lifetime Premium Member
Good news! There is also a sticky at the top of the W210 forum for those. You can try to clean them, buy just the insert, or buy the whole unit. Check with Autohausaz for the parts, but you'll probably be able to find the cleaning solution somewhere locally. If you choose the cleaning route, make sure it is the right stuff (CRC-something). Good Luck.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    E320 wagon, 4matic or Not. BillNouj W210 E-Class 9 05-07-2006 11:49 PM
    MY 2000 - E320 4matic wagon Sanjay W210 E-Class 1 05-06-2005 05:32 PM
    1999 e320 4matic maninblack W210 E-Class 7 04-11-2005 06:57 AM
    E320 4Matic Wagon. How is it? 1985 300CD W210 E-Class 5 01-25-2005 06:45 PM
    FS: 1999 E320 4MATIC reuvenh W210 E-Class 0 05-02-2003 11:37 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome