A/C won't work! Mechanics can't figure it out. Help! - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 07-19-2008, 05:43 PM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2008
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
A/C won't work! Mechanics can't figure it out. Help!

I bought a used 1991 350-SD a few months ago. A/C worked so so. About 2 months ago A/C began blowing luke warm air and then worked fine sporatically. As of 1 month ago A/C doesn't work at all. I've determined the compressor will not turn on (it's not a freon leak). It works once in a while, and when it does it's ice cold. But most of the time when you push the "on" button on the climate control unit the compressor doesn't come on and it blows red hot air.

I've had the car to 3 inde MB shops. The first charged me $200 to tell me it was the electric relay under the hood. So I bought a new relay for $300. Still nothing. The 2 other shops couldn't figure it out after a week at each place and didn't charge me. The last shop did jump the relay and did get the A/C to work. They took out the relay and bridged 2 holes with a wire and it worked. It worked all day and the next day when I started the car it didn't work.

I'm really at my wits end with this. The climate I live is 110-118 F degrees 5 months out of the year. The shops are all 45 mins from my house. Any assistance would be appreciated. My next step is to put in a new compressor but this sounds more like an electrical fault issue.
johnhere is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 07-19-2008, 05:49 PM
BenzWorld Elite
 
flyboyike's Avatar
 
Date registered: May 2003
Vehicle: 2012 Focus SE
Location: Ormond Beach, FL
Posts: 7,704
Mentioned: 1 Post(s)
Quoted: 70 Post(s)
Has the push-button unit been tested?

Felicita e un bicchiere di vino con un panino.
flyboyike is offline  
post #3 of 4 (permalink) Old 07-19-2008, 07:33 PM Thread Starter
BenzWorld Junior Member
 
Date registered: May 2008
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
No, the push button unit hasn't been tested. And at this point it doesn't matter since I was so pissed off today I snaped and put my foot right thru the center console. The push button unit, wood trim, radio, and buttons are now in 5,000 pieces.

I ordered a refurbed push button unit for $250 and if that doesn't work I'm parking the car in the slums with the keys in it and windows down and someone else can deal with it.
johnhere is offline  
 
post #4 of 4 (permalink) Old 07-20-2008, 11:54 AM
~BANNED~
 
Date registered: Sep 2007
Vehicle: 99 Merc S420 (80k Mi) 07 Lexus LS460 (21k Miles)
Location: FL
Posts: 4,583
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Where are you? I'll take the car for free.....with a smile.
mr.xpowerseller is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Can't figure this out..please HELP! TpaBenZo W124 E,CE,D,TD Class 6 06-28-2009 10:14 PM
can you figure this one out??? eurosdpec W201 190-Class 10 02-06-2008 03:18 PM
Help me figure this out please IN-FLT General Mercedes-Benz 5 12-21-2007 06:44 PM
Figure this one out: Mattiesbenz W123 E,CE,D,CD,TD,TE Class 8 12-02-2005 05:08 AM
Did some diagnostic work, trying to figure my idle problem..... djimmy31 W124 E,CE,D,TD Class 0 10-21-2003 04:19 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome