I'm New Too - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 07-08-2008, 02:16 PM Thread Starter
BenzWorld Newbie
Date registered: Jul 2008
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
I'm New Too

I have a 2004 C230 Sport, I know it's not the best of ones but what can I say I got it for xmas 2 years ago. I did notice today while putin around town that the a/c works fine on the right side but the drivers side was blowing hot air. I know that's not suppose to happen even to the worst of cars. So before I drag it down to the dealershit..I mean dealership, any idea's on what the problem might be.



Last edited by Daytona500Jr08@yahoo.com; 07-08-2008 at 02:17 PM. Reason: misspelling
Daytona500Jr08@yahoo.com is offline  
Sponsored Links
post #2 of 3 (permalink) Old 07-08-2008, 06:34 PM Thread Starter
BenzWorld Newbie
Date registered: Jul 2008
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
little more info

it was between 99 and 102 degrees today, the car does have a supercharger 6 speed manual, 1st time this has happened, the car is in the garage and not moving till I can figure out what is wrong, if that is any help? i do not misstreat my car the out come from my wife would be worse so all help would be cool. i did speak to my neighboro he said it maybe low on ferion cant spell or it might be a heater valve? any idea's be welcomed
Daytona500Jr08@yahoo.com is offline  
post #3 of 3 (permalink) Old 07-08-2008, 08:36 PM
BenzWorld Elite
Jayhawk's Avatar
Date registered: Aug 2005
Vehicle: S500/W220/2000
Location: Lawrence, KS (USA)
Posts: 21,652
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
Welcome a-board John! I have no idea what might be wrong w/ your A/C but I would take it to the dealer. You might also post this question on the appropriate forum here for your model car. Someone there might know something.

Don't believe everything you think
Jayhawk is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome