idle issues - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 06-23-2008, 01:56 PM Thread Starter
BenzWorld Newbie
Date registered: Jun 2008
Vehicle: 1989 mercedes 190E 2.6L
Location: Independence, IA
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Post idle issues

Hello, all. I am new to this forum. I have owned my 1989 190e 2.6L for almost 4yrs now. I have been having a few issues with it as of late though. It currently has a problem with idling. when I start it, it revs up to @2000 rpm, then it drops to about 1100rpm, then bounces from 1100rpm to 1800rpm constantly. I have checked all of the vaccum hoses and I didn't find any leaks. I have also just replaced the spark plugs, and distributor cap and rotor. I have also checked all of the fuses and cleaned all of the plugs sensors that I could reach. Does anyone have any idea what could be causing my idling issues?

fzr400racer is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Idle Issues m4411b W201 190-Class 1 05-27-2008 04:30 PM
    S600 low battery issues (Limp home, Idle issues, P1581 DTC and ESP lamp)... bdkorn W140 S-Class 8 04-07-2008 09:24 PM
    idle issues rzsquared W123 E,CE,D,CD,TD,TE Class 8 10-06-2007 11:45 AM
    Let's have another go at idle issues! CowtownBallin W124 E,CE,D,TD Class 11 02-26-2007 05:47 AM
    idle issues mobeyone W203 C32 AMG, C55 AMG 0 10-09-2005 05:00 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome