Suspect sensor problem - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 06-17-2008, 11:44 AM Thread Starter
BenzWorld Newbie
Date registered: Jun 2008
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Suspect sensor problem

I have a 2000 E320, last week I had an AC recharge service done. The AC is working fine now, but I noticed that the engine shuts off during idle every time I turned the AC on and I can not start the engine again I have to wait few minutes some time more to start the engine back up. First, is there any relation to the AC being turned on? Second what is causing the engine to shut off? Thanks.
nooreddine is offline  
Sponsored Links
post #2 of 4 (permalink) Old 06-17-2008, 12:30 PM
BenzWorld Elite
Kajtek1's Avatar
Date registered: Dec 2005
Vehicle: W211 E320 Bluetec R129 SL500 - $1300 car ........ Ford F350 6l
Location: CA Bay Area
Posts: 31,511
Mentioned: 9 Post(s)
Quoted: 1058 Post(s)
Welcome to the forum. AC itself can't kill the engine, but if the engine is having a problem performing poorly at idle and you turn AC at this time, it might overload the engine.
Do you have any error codes? Is engine showing any other problems?
Failure to restart hot engine is mostly related to failing CPS, but it is long shoot.
Kajtek1 is offline  
post #3 of 4 (permalink) Old 06-17-2008, 04:03 PM Thread Starter
BenzWorld Newbie
Date registered: Jun 2008
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
No, error codes, and I do not see any other problem with the engine. car has 77K miles.
nooreddine is offline  
post #4 of 4 (permalink) Old 06-17-2008, 05:27 PM
Lifetime Premium Member
Musikmann's Avatar
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
Lifetime Premium Member
Kajtek1 is making an educated guess based on a lot of W210 owners experiences. Your symptoms certainly sound like a bad crankshaft (not camshaft) position sensor. Have a look at the Stickys at the top of the W210 section and you will see this described in greater detail.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Vacuum=Prime suspect? BetseyBenz W123 E,CE,D,CD,TD,TE Class 14 12-26-2011 02:26 PM
    Rought idle, suspect IAT sensor Raksan W202 C-Class 1 03-12-2008 06:30 PM
    suspect engine noise BillNouj W163 M-Class 10 07-26-2007 08:18 PM
    suspect oil in my intercooler benkokes R170 SLK-Class 10 01-25-2005 08:09 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome