C200 WINDOW FUSE BLOWING - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 05-28-2008, 09:15 PM Thread Starter
BenzWorld Newbie
Date registered: May 2008
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)

Hello can anyone help?
I have a 1995 C280 the rear windows work fine, the front ones dont.
The fuse keeps blowing that powers the front windows, the fuse is located in the boot.
I think it could be a bad earth, has anyone had this problem? How did you stop the fuse from blowing?
WPD is offline  
Sponsored Links
post #2 of 2 (permalink) Old 05-28-2008, 10:17 PM
BenzWorld Elite
Diesel Benz's Avatar
Date registered: Dec 2005
Vehicle: 222.132 & 221.122 & 212.025 & 906.633
Location: Europe
Posts: 10,320
Mentioned: 3 Post(s)
Quoted: 32 Post(s)
Bad earth would mean additional resistance and lower current, would not blow a fuse. A bad hot wire that touches ground would be a different issue.

But are the windows moving smoothly enough, perhaps just a lubrication issue (or something worn out making it hard to move).
Diesel Benz is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Fuse No. 30 keeps blowing mgill85258 W140 S-Class 5 09-11-2007 05:14 PM
    rear heated window defrost fuse keep blowing out??? mbnz230 W140 S-Class 0 12-11-2006 06:34 PM
    fuse # 16 blowing bayhas W140 S-Class 5 07-16-2006 12:31 AM
    Fuse blowing surbenzolot W163 M-Class 2 04-18-2005 08:08 PM
    Fuse keeps blowing gordinho80 W124 E,CE,D,TD Class 3 03-13-2003 07:48 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome